summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRand01ph2020-08-24 15:31:55 +0800
committerRand01ph2020-08-24 15:31:55 +0800
commitc25c86166d13a7897151b1e35cfcf58cf3bfbc1a (patch)
treee5f555a32b4bbba7c1e33694935ab91a22f4f9b2
downloadaur-c25c86166d13a7897151b1e35cfcf58cf3bfbc1a.tar.gz
first commit
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD32
-rw-r--r--tim.install10
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1308722cae1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.qq.tim.dcs
+ pkgdesc = Tencent TIM Client on Deepin Wine 5 (from Spark Store)
+ pkgver = 3.1.0.21789
+ pkgrel = 1
+ url = http://tim.qq.com/
+ install = tim.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = http://dcstore.shenmo.tech/store/chat/com.qq.tim.dcs/com.qq.tim.dcs_3.1.0.21789_i386.deb
+ sha512sums = 84de5249869940898324977c7312f1ad61567748fb4a6b5a513da64b1308fbad98bcb6af7a87a9c39a9284d97b96a9f3901abcb9d296b0ef778df051792ccdfe
+
+pkgname = com.qq.tim.dcs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..6b15b9934042
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Rand01ph <tanyawei1991@gmail.com>
+pkgname=com.qq.tim.dcs
+pkgver=3.1.0.21789
+pkgrel=1
+epoch=
+pkgdesc="Tencent TIM Client on Deepin Wine 5 (from Spark Store)"
+arch=('i686' 'x86_64')
+url="http://tim.qq.com/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+#conflicts=('deepin-wine-tim')
+replaces=()
+backup=()
+options=()
+install=tim.install
+changelog=
+source=("http://dcstore.shenmo.tech/store/chat/${pkgname}/${pkgname}_${pkgver}_i386.deb")
+sha512sums=('84de5249869940898324977c7312f1ad61567748fb4a6b5a513da64b1308fbad98bcb6af7a87a9c39a9284d97b96a9f3901abcb9d296b0ef778df051792ccdfe')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+}
diff --git a/tim.install b/tim.install
new file mode 100644
index 000000000000..71c57b79b7ac
--- /dev/null
+++ b/tim.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/DCS-TIM to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing TIM bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/DCS-TIM/ \;
+}