summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhuang2022-08-14 13:16:10 +0800
committerzhuang2022-08-14 13:16:10 +0800
commitaee0a677262445a1d562154cfbfaef79a15c0b68 (patch)
treed7dda518eb016301abc991106e0b99a4d3810ba5
parent2b094d8012ee63ff5a65018840023ba76374110b (diff)
downloadaur-aee0a677262445a1d562154cfbfaef79a15c0b68.tar.gz
update 3.7.5.11spark7
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD25
-rw-r--r--app.json16
3 files changed, 33 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6f108e4cfae..7b6ce44a6f92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = com.qq.weixin.spark
pkgdesc = Tencent WeChat Client on Deepin Wine 5 (from Spark Store)
- pkgver = 3.2.1.127spark0
+ pkgver = 3.7.5.11spark7
pkgrel = 1
url = http://weixin.qq.com/
install = wechat.install
@@ -14,7 +14,9 @@ pkgbase = com.qq.weixin.spark
optdepends = noto-fonts-cjk: Google Noto CJK fonts
conflicts = com.qq.weixin.dcs
replaces = com.qq.weixin.dcs
- source = https://sucdn.jerrywang.top/store/chat/com.qq.weixin.spark/com.qq.weixin.spark_3.2.1.127spark0_i386.deb
- md5sums = d4c75622d33e5ae5f8d59f0b6b70de00
+ source = http://d.store.deepinos.org.cn//store/chat/com.qq.weixin.spark/app.json
+ source = http://d.store.deepinos.org.cn//store/chat/com.qq.weixin.spark/com.qq.weixin.spark_3.7.5.11spark7_i386.deb
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = com.qq.weixin.spark
diff --git a/PKGBUILD b/PKGBUILD
index d08bb055f12b..1bd77a2a0d99 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: Sam L. Yes <samlukeyes123@gmail.com>
+# Maintainer: zhuangzhuang <xufengyuan20080802@outlook.com>
pkgname=com.qq.weixin.spark
-pkgver=3.2.1.127spark0
+pkgver=3.7.5.11spark7
pkgrel=1
-epoch=
pkgdesc="Tencent WeChat Client on Deepin Wine 5 (from Spark Store)"
arch=('i686' 'x86_64')
url="http://weixin.qq.com/"
license=('unknown')
-groups=()
depends=('deepin-wine5' 'deepin-wine-helper' 'xdg-utils')
#makedepends=('tar')
-checkdepends=()
optdepends=('ttf-ms-fonts: Microsoft Core fonts (You might also need Microsoft YaHei additionally)'
- 'noto-fonts-cjk: Google Noto CJK fonts')
-provides=()
+ 'noto-fonts-cjk: Google Noto CJK fonts')
conflicts=('com.qq.weixin.dcs')
replaces=('com.qq.weixin.dcs')
-backup=()
-options=()
install=wechat.install
-changelog=
-source=("https://sucdn.jerrywang.top/store/chat/${pkgname}/${pkgname}_${pkgver}_i386.deb")
-md5sums=('d4c75622d33e5ae5f8d59f0b6b70de00')
-validpgpkeys=()
+source=("http://d.store.deepinos.org.cn//store/chat/com.qq.weixin.spark/app.json"
+ "http://d.store.deepinos.org.cn//store/chat/com.qq.weixin.spark/${pkgname}_${pkgver}_i386.deb")
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cat app.json | sed 's/,/\n/g' | grep "Version" | sed 's/:/\n/g' | sed '1d' | sed 's/}//g' | sed 's/"//g' | python -c "s=input();print(s.strip())"
+}
+
package() {
cd ${pkgdir}
diff --git a/app.json b/app.json
new file mode 100644
index 000000000000..df9cf2cc8ca0
--- /dev/null
+++ b/app.json
@@ -0,0 +1,16 @@
+{
+ "Name": "微信(wine)",
+ "Version": "3.7.5.11spark7",
+ "Filename": "com.qq.weixin.spark_3.7.5.11spark7_i386.deb",
+ "Torrent_address": "com.qq.weixin.spark_3.7.5.11spark7_i386.deb.torrent",
+ "Pkgname": "com.qq.weixin.spark",
+ "Author": "腾讯",
+ "Contributor": "sgb76",
+ "Website": "https://weixin.qq.com/",
+ "Update": "2022-07-10 12:27:04",
+ "Size": "211.07 MB",
+ "More": "微信PC客户端 \n\n更新说明:\n1.deepin下运行效果较好,各项功能(包括朋友圈、小程序、视频通话、截图等)均可正常使用;\n2.修复了Ubuntu22.04下不显示图片的问题,但摄像头、小程序、截图等仍然存在问题。",
+ "Tags": "deepin;ubuntu;dwine5",
+ "img_urls": "[\"https://examine-spark.oss-cn-shanghai.aliyuncs.com/images/2022/07/10/40257b50-0008-11ed-af5d-3bbfdc90d8e6.png\",\"https://examine-spark.oss-cn-shanghai.aliyuncs.com/images/2022/07/10/4268b490-0008-11ed-af5d-3bbfdc90d8e6.png\",\"https://examine-spark.oss-cn-shanghai.aliyuncs.com/images/2022/07/10/454b6220-0008-11ed-af5d-3bbfdc90d8e6.png\"]",
+ "icons": "https://examine-spark.oss-cn-shanghai.aliyuncs.com/icons/2022/07/10/3d7f1370-0008-11ed-af5d-3bbfdc90d8e6.png"
+} \ No newline at end of file