summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2020-12-17 17:10:58 +0800
committerYour Name2020-12-17 17:10:58 +0800
commit3cd180bd93af452bd06630f0d614724a215342f1 (patch)
tree59a3557dc49a7527df6b9982b6dfaa4b1d6e6944
downloadaur-3cd180bd93af452bd06630f0d614724a215342f1.tar.gz
Pack com.tdx.deepin
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD37
-rw-r--r--tongdaxing.install10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25df2664f0a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.tdx.deepin
+ pkgdesc = tongdaxing on Deepin Wine5
+ pkgver = 7.52
+ pkgrel = 1
+ url = https://www.tdx.com.cn/
+ install = tongdaxing.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5-stable>=5.0.0.16
+ depends = deepin-wine-helper
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.tdx.deepin/com.tdx.deepin_7.52deepin1_i386.deb
+ sha512sums = 8f2f0fca6fbc071cf820ae99c8164b50486bb6abc21fb520eb9ae46eb005ebe6dfc44d04b48d4bdb1dd76c30384da82c41aae4d6ee19e3bcd6a3c089eb1f79d7
+
+pkgname = com.tdx.deepin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a5275f66f5cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=com.tdx.deepin
+pkgver=7.52
+pkgrel=1
+epoch=
+pkgdesc="tongdaxing on Deepin Wine5"
+arch=('i686' 'x86_64')
+url="https://www.tdx.com.cn/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5-stable>=5.0.0.16' 'deepin-wine-helper' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=tongdaxing.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('8f2f0fca6fbc071cf820ae99c8164b50486bb6abc21fb520eb9ae46eb005ebe6dfc44d04b48d4bdb1dd76c30384da82c41aae4d6ee19e3bcd6a3c089eb1f79d7')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}
diff --git a/tongdaxing.install b/tongdaxing.install
new file mode 100644
index 000000000000..16e7d5127f78
--- /dev/null
+++ b/tongdaxing.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/Deepin-TDX to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing TDX bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-TDX/ \;
+} \ No newline at end of file