summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkerojiang2020-10-27 21:03:46 +0800
committerkerojiang2020-10-27 21:03:46 +0800
commitd2086e4acd640d3b273f2b0d44af4869de691b20 (patch)
tree50cc3cc18d195249b7db09397110d58ff513ddf8
downloadaur-d2086e4acd640d3b273f2b0d44af4869de691b20.tar.gz
init package
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD35
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e48f205b1930
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.xiaokanba.bbs.spark
+ pkgdesc = 闪电下载(来自深度应用商店)
+ pkgver = 1.4.7.0spark0
+ pkgrel = 1
+ url = http://bbs.xiaokankba.com/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5
+ depends = deepin-wine-helper
+ depends = xdg-utils
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ conflicts = com.xiaokanba.bbs
+ replaces = com.xiaokanba.bbs
+ source = https://sucdn.jerrywang.top/store/network/com.xiaokanba.bbs.spark/com.xiaokanba.bbs.spark_1.4.7.0spark0_i386.deb
+ md5sums = 52dc66e201972cf0bcba37b32db6d769
+
+pkgname = com.xiaokanba.bbs.spark
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5a079ecad7ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.deb
+*.rpm
+.AppImage
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dda445cde64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: kerojiang <kerojiang@126.com>
+pkgname=com.xiaokanba.bbs.spark
+pkgver=1.4.7.0spark0
+pkgrel=1
+epoch=
+pkgdesc="闪电下载(来自深度应用商店)"
+arch=('i686' 'x86_64')
+url="http://bbs.xiaokankba.com/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5' 'deepin-wine-helper' 'xdg-utils')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+conflicts=('com.xiaokanba.bbs')
+replaces=('com.xiaokanba.bbs')
+backup=()
+options=()
+#install=wechat.install
+changelog=
+source=("https://sucdn.jerrywang.top/store/network/${pkgname}/${pkgname}_${pkgver}_i386.deb")
+md5sums=('52dc66e201972cf0bcba37b32db6d769')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries/
+ rm -rf usr/share/doc
+ rm opt/apps/${pkgname}/info
+}