summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVHSgunzo2023-10-22 19:42:54 +0300
committerVHSgunzo2023-10-22 19:42:54 +0300
commitead2934945de319f26b09d62fc927206b5f38ced (patch)
tree4be5fcc186869fef1dc7d6ea5902c25f902bf8a7
downloadaur-ead2934945de319f26b09d62fc927206b5f38ced.tar.gz
v0.4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58b40402512f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = combaud-git
+ pkgdesc = Broadcasting audio output from applications to a virtual microphone
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/VHSgunzo/combaud
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = pipewire
+ depends = grep
+ depends = sed
+ depends = coreutils
+ depends = libpulse
+ depends = gawk
+ provides = combaud-git
+ provides = combaud
+ conflicts = combaud-git
+ conflicts = combaud
+ source = git+https://github.com/VHSgunzo/combaud.git
+ sha256sums = SKIP
+
+pkgname = combaud-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a81f1407f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: VHSgunzo <vhsgunzo.github.io>
+pkgname='combaud-git'
+pkgver=0.4.r0.g7ae9a89
+pkgrel=1
+pkgdesc='Broadcasting audio output from applications to a virtual microphone'
+arch=('any')
+url='https://github.com/VHSgunzo/combaud'
+license=('MIT')
+depends=('pipewire' 'grep' 'sed' 'coreutils' 'libpulse' 'gawk')
+makedepends=('git')
+provides=("$pkgname" "${pkgname%-git}")
+conflicts=("${provides[@]}")
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 'combaud' "$pkgdir/usr/bin/combaud"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/combaud/LICENSE"
+}