summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2017-10-19 17:18:25 -0700
committerGavin Lloyd2017-10-19 17:18:25 -0700
commit10c8ac087feb06faa19f4ffab5dd19ef5a6c5bd4 (patch)
tree4123d07325c9edf3a14a205b4e729dee7b83f433
parent6b867d63617edafcd1fa1c8d84f0ce1f0de1f1be (diff)
downloadaur-10c8ac087feb06faa19f4ffab5dd19ef5a6c5bd4.tar.gz
Update to 0.68.b866d9b
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16d3d862847f..11a711045c6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Feb 24 19:29:21 UTC 2017
+# Fri Oct 20 00:18:10 UTC 2017
pkgbase = combust-git
pkgdesc = nftables firewall script with profiles
- pkgver = 0.66.6779dd2
- pkgrel = 2
+ pkgver = 0.68.b866d9b
+ pkgrel = 1
url = https://github.com/gavinhungry/combust
arch = any
license = MIT
depends = nftables
backup = etc/combust.conf
- source = combust::git+https://github.com/gavinhungry/combust.git#branch=master
+ source = combust-git::git+https://github.com/gavinhungry/combust.git#branch=master
sha256sums = SKIP
pkgname = combust-git
diff --git a/PKGBUILD b/PKGBUILD
index 246c951a7142..78365807934d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,27 @@
# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
pkgname=combust-git
-_gitname=combust
-pkgver=0.66.6779dd2
-pkgrel=2
+pkgver=0.68.b866d9b
+pkgrel=1
pkgdesc='nftables firewall script with profiles'
arch=('any')
-license=('MIT')
url='https://github.com/gavinhungry/combust'
+license=('MIT')
depends=('nftables')
-source=("${_gitname}::git+https://github.com/gavinhungry/${_gitname}.git#branch=master")
-sha256sums=('SKIP')
backup=('etc/combust.conf')
+source=("${pkgname}::git+https://github.com/gavinhungry/combust.git#branch=master")
+sha256sums=('SKIP')
-pkgver () {
- cd "${srcdir}/${_gitname}"
- echo "0.$(git rev-list --count HEAD).$(git describe --always | sed 's|-|.|g')"
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "0.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${pkgname}"
- install -d $pkgdir/etc/
- install -d $pkgdir/usr/bin/
- install -d $pkgdir/usr/lib/systemd/system/
- install -m600 combust.conf "${pkgdir}"/etc/
- install -m755 combust.sh "${pkgdir}"/usr/bin/combust
- install -m644 combust.service "${pkgdir}"/usr/lib/systemd/system/
+ install -Dm600 combust.conf "${pkgdir}"/etc/combust.conf
+ install -Dm755 combust.sh "${pkgdir}"/usr/bin/combust
+ install -Dm644 combust.service "${pkgdir}"/usr/lib/systemd/system/combust.service
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}