summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-06-09 17:20:29 -0700
committerGavin Lloyd2015-06-09 17:20:29 -0700
commit512912f130bd636ea004e77fc47417f8735adb6f (patch)
tree67162202631a51f27e5e8e850d0e848e39b4988e
downloadaur-512912f130bd636ea004e77fc47417f8735adb6f.tar.gz
Init commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39ebfe9d9d59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = combust-git
+ pkgdesc = iptables/nftables firewall script with profiles
+ pkgver = 0.50.0dcc612
+ pkgrel = 1
+ url = https://github.com/gavinhungry/combust
+ arch = any
+ license = MIT
+ depends = iptables
+ depends = nftables
+ backup = etc/combust/combust.conf
+ source = combust::git+https://github.com/gavinhungry/combust.git#branch=master
+ md5sums = SKIP
+
+pkgname = combust-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac4f1c85f53c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=combust-git
+_gitname=combust
+pkgver=0.50.0dcc612
+pkgrel=1
+pkgdesc='iptables/nftables firewall script with profiles'
+arch=('any')
+license=('MIT')
+url='https://github.com/gavinhungry/combust'
+depends=('iptables' 'nftables')
+source=("${_gitname}::git+https://github.com/gavinhungry/${_gitname}.git#branch=master")
+md5sums=('SKIP')
+backup=('etc/combust/combust.conf')
+
+pkgver () {
+ cd "${srcdir}/${_gitname}"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always | sed 's|-|.|g')"
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ install -d $pkgdir/etc/combust/
+ install -d $pkgdir/usr/lib/systemd/system/
+ install -m755 combust.sh "${pkgdir}"/etc/combust/
+ install -m755 combust-nft.sh "${pkgdir}"/etc/combust/
+ install -m600 combust.conf "${pkgdir}"/etc/combust/
+ install -m644 combust.service "${pkgdir}"/usr/lib/systemd/system/
+ install -m644 combust-nft.service "${pkgdir}"/usr/lib/systemd/system/
+}