summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2017-12-20 17:50:25 +0100
committerXiretza2017-12-20 17:52:01 +0100
commit4324f38722ddcd6fcaca16287b9e6fce9019af80 (patch)
tree2efaab7e931e6e73f8d37f67527fc725b8accc1a
parentcbc8c9ea332fee3c383803863a2841f900baa0ff (diff)
downloadaur-4324f38722ddcd6fcaca16287b9e6fce9019af80.tar.gz
Bump to 0.6.4, rewrite PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 111a63ac2f37..befda5e2cbbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = combustion
pkgdesc = Sleek, modern web interface for Transmission
- pkgver = 0.6.2
- pkgrel = 2
+ pkgver = 0.6.4
+ pkgrel = 1
url = https://github.com/Secretmapper/combustion
arch = any
license = MIT
makedepends = git
depends = transmission-cli
- source = git+https://github.com/Secretmapper/combustion.git
+ source = combustion::git+https://github.com/Secretmapper/combustion#commit=e4b15ec
source = combustion.sh
source = combustion.conf
- sha1sums = SKIP
- sha1sums = 1b2e73e143508792e94bd7d35f2e0d68b837527a
- sha1sums = 449f682b9c6cb896d0650104c45bbdc07afcfece
+ sha256sums = SKIP
+ sha256sums = 3d19c6507db71262cf8757e10c0b692f5386d78314ea2b2cdd569d6d0ebbf90e
+ sha256sums = 32d85f5b3b842f88fe573d1af3e20727797b75d53db0e70b68c4e521a9f8e339
pkgname = combustion
diff --git a/PKGBUILD b/PKGBUILD
index 6c657e6f8242..0705dc574f21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
-# Maintainer: gato_lento <vukk.euob at gmail>
+# Maintainer: xiretza <xiretza+aur@gmail.com>
+# Contributor: gato_lento <vukk.euob at gmail>
pkgname=combustion
-pkgver=0.6.2
-pkgrel=2
+pkgver=0.6.4
+# necessary due to broken "release" process
+_vercommit=e4b15ec
+pkgrel=1
pkgdesc='Sleek, modern web interface for Transmission'
arch=('any')
url='https://github.com/Secretmapper/combustion'
@@ -9,24 +12,20 @@ license=('MIT')
depends=('transmission-cli')
makedepends=('git')
-source=(
- git+https://github.com/Secretmapper/combustion.git
- combustion.sh
- combustion.conf
-)
+source=("${pkgname}::git+${url}#commit=${_vercommit}"
+ combustion.sh
+ combustion.conf)
-sha1sums=(
- SKIP
- 1b2e73e143508792e94bd7d35f2e0d68b837527a
- 449f682b9c6cb896d0650104c45bbdc07afcfece
-)
+sha256sums=('SKIP'
+ '3d19c6507db71262cf8757e10c0b692f5386d78314ea2b2cdd569d6d0ebbf90e'
+ '32d85f5b3b842f88fe573d1af3e20727797b75d53db0e70b68c4e521a9f8e339')
package() {
- install -D -m755 $srcdir/combustion.sh $pkgdir/etc/profile.d/combustion.sh
- install -D -m644 $srcdir/combustion.conf $pkgdir/usr/lib/systemd/system/transmission.service.d/combustion.conf
- cd $srcdir/combustion
- git checkout v${pkgver}
- install -D -m644 $srcdir/combustion/LICENSE $pkgdir/usr/share/licenses/combustion/LICENSE
- cp -r $srcdir/combustion $pkgdir/usr/share/
- rm -rf $pkgdir/usr/share/combustion/{LICENSE,.git}
+ cd "$srcdir/$pkgname"
+ install -D -m755 "$srcdir/combustion.sh" "$pkgdir/etc/profile.d/combustion.sh"
+ install -D -m644 "$srcdir/combustion.conf" "$pkgdir/usr/lib/systemd/system/transmission.service.d/combustion.conf"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 -t "$pkgdir/usr/share/$pkgname" asset-manifest.json favicon.ico index.html main.77f9cffc.css
+ cp -r static "$pkgdir/usr/share/$pkgname"
}