summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanadeep Biswas2023-03-09 00:30:37 +0100
committerRanadeep Biswas2023-03-09 00:30:37 +0100
commit9bd3c714fadcb8e73554e8426e22b6979db97919 (patch)
tree3e60350d45482ecb83bd3658f7cc8da20ca83f25
downloadaur-9bd3c714fadcb8e73554e8426e22b6979db97919.tar.gz
v0.37.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdfe3c695114
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cometbft-bin
+ pkgdesc = CometBFT: A distributed, Byzantine fault-tolerant, deterministic state machine replication engine, and fork of Tendermint Core.
+ pkgver = 0.37.0
+ pkgrel = 1
+ url = https://cometbft.com
+ arch = x86_64
+ arch = aarch64
+ arch = armv6h
+ license = Apache
+ provides = cometbft
+ conflicts = cometbft
+ source_x86_64 = https://github.com/cometbft/cometbft/releases/download/v0.37.0/cometbft_0.37.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = 283e7cb914daf7e2f1687609143dac152d04852ad5a64c647b07cbfcd10f4577
+ source_aarch64 = https://github.com/cometbft/cometbft/releases/download/v0.37.0/cometbft_0.37.0_linux_arm64.tar.gz
+ sha256sums_aarch64 = 4ed89fcc1737072aed03b6b254b367dca754e510e46dee6c43180af8416a64d5
+ source_armv6h = https://github.com/cometbft/cometbft/releases/download/v0.37.0/cometbft_0.37.0_linux_armv6.tar.gz
+ sha256sums_armv6h = 4b2295ba2bc0fcefdb719a5e8d974225d50c47760336a09d5befd6b56c575445
+
+pkgname = cometbft-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6915daf9d59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ranadeep B < mail at rnbguy dot at >
+
+_orgname=cometbft
+_pkgname=cometbft
+pkgname=${_pkgname}-bin
+pkgver=0.37.0
+pkgrel=1
+pkgdesc="CometBFT: A distributed, Byzantine fault-tolerant, deterministic state machine replication engine, and fork of Tendermint Core."
+arch=('x86_64' 'aarch64' 'armv6h')
+url="https://${_pkgname}.com"
+license=('Apache')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source_x86_64=("https://github.com/${_orgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
+source_aarch64=("https://github.com/${_orgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
+source_armv6h=("https://github.com/${_orgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.tar.gz")
+sha256sums_x86_64=('283e7cb914daf7e2f1687609143dac152d04852ad5a64c647b07cbfcd10f4577')
+sha256sums_aarch64=('4ed89fcc1737072aed03b6b254b367dca754e510e46dee6c43180af8416a64d5')
+sha256sums_armv6h=('4b2295ba2bc0fcefdb719a5e8d974225d50c47760336a09d5befd6b56c575445')
+
+package() {
+ install -Dt "$pkgdir/usr/local/bin" "$_pkgname"
+ install -m644 -Dt "$pkgdir/usr/share/licenses/$_pkgname" LICENSE
+}