summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Santiago2019-04-15 09:18:23 +0200
committerDavid Santiago2019-04-15 09:18:23 +0200
commit20e26d9f8b99ee47cd53d61d30979d9c22a1c79d (patch)
tree83368b4823b539d38938f17fefe453713840a996
downloadaur-20e26d9f8b99ee47cd53d61d30979d9c22a1c79d.tar.gz
First release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
-rw-r--r--comma-ide.install30
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..369a7fe14cdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = comma-ide-community
+ pkgdesc = The Integrated Development Environment for Perl 6.
+ pkgver = 2019.3.0.1
+ pkgrel = 1
+ url = https://commaide.com/
+ install = comma-ide.install
+ arch = any
+ license = APACHE
+ depends = java-runtime
+ optdepends = rakudo-star
+ optdepends = rakudo
+ provides = _pkgname
+ source = https://commaide.com/download/community/linux
+ sha512sums = 972b7c722622e1184c224d2a405ecda8018ee04789d0b74fab0978a2f14f4b8bb92e41dfdab78176d729951e68064446bdba140c936fa05919b968cead161d77
+
+pkgname = comma-ide-community
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..139e64b4030d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: David Santiago <demanuel@ymail.com>
+pkgname=comma-ide-community
+_pkgname=comma-ide
+_tarname=comma-community
+pkgrel=1
+pkgver=2019.3.0.1
+provides=(_pkgname)
+pkgdesc="The Integrated Development Environment for Perl 6."
+arch=('any')
+url="https://commaide.com/"
+license=('APACHE')
+depends=('java-runtime')
+optdepends=('rakudo-star' 'rakudo')
+source=("https://commaide.com/download/community/linux")
+sha512sums=('972b7c722622e1184c224d2a405ecda8018ee04789d0b74fab0978a2f14f4b8bb92e41dfdab78176d729951e68064446bdba140c936fa05919b968cead161d77')
+install=comma-ide.install
+
+package() {
+set -xv
+ mkdir -p $pkgdir/opt/ $pkgdir/usr/bin/ $pkgdir/usr/share/applications/ ${pkgdir}/usr/share/icons/
+ cp -R $srcdir/${_tarname}-${pkgver:0:6} $pkgdir/opt/
+
+ cat <<EOF > $pkgdir/usr/share/applications/${_pkgname}.desktop
+[Desktop Entry]
+Exec=/usr/bin/comma %f
+Icon=${_pkgname}
+Terminal=false
+Type=Application
+Name=Comma IDE
+Comment=The Integrated Development Environment for Perl 6
+Categories=Development;IDE;TextEditor;
+MimeType=text/plain;inode/directory;
+StartupNotify=true
+StartupWMClass=code
+EOF
+
+ ln -s /opt/${_tarname}-${pkgver:0:6}/bin/comma.png ${pkgdir}/usr/share/icons/${_pkgname}.png
+ ln -s /opt/${_tarname}-${pkgver:0:6}/bin/comma.sh $pkgdir/usr/bin/comma
+ set +xv
+}
+
+
diff --git a/comma-ide.install b/comma-ide.install
new file mode 100644
index 000000000000..de8b84104e1e
--- /dev/null
+++ b/comma-ide.install
@@ -0,0 +1,30 @@
+post_install(){
+
+ cat <<EOF
+ *Notes*
+ To adjust the value of the JVM heap size, create
+ ~/.CommaCT2019.3/comma.vmoptions (or comma64.vmoptions
+ if using a 64-bit JDK), and set the -Xms and -Xmx parameters. To see how
+ to do this, you can reference the vmoptions file in the bin folder
+
+ [OPTIONAL] Changing the location of "config" and "system" directories
+ ------------------------------------------------------------------------------
+ By default, Comma stores all your settings under the ~/.CommaCT2019.3/config
+ directory and uses ~/.CommaCT2019.3/system as a data cache.
+ If you want to change these settings,
+
+ 1. Open a console and cd into ~/.CommaCT2019.3/config
+
+ 2. Create the file "idea.properties" and open it in an editor. Set the
+ idea.system.path and/or idea.config.path variables as desired, for
+ example:
+
+ idea.system.path=~/custom/system
+ idea.config.path=~/custom/config
+
+ 3. Note that we recommend to store data cache ("system" directory) on a disk
+ with at least 1GB of free space.
+EOF
+
+}
+