summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Hellberg2023-08-05 19:51:43 +0200
committerAdam Hellberg2023-08-05 19:51:43 +0200
commitb122f177f92985e02adeece64d9f7d2a872bc5de (patch)
tree9516d8b26f20f00802a64c08ec457b97da31ebdc
parent4284644d7aa0c592f25100cd7b41096f5ae4dcf2 (diff)
parentddcb724756bf69af42d74833b1855a79f2185dfc (diff)
downloadaur-b122f177f92985e02adeece64d9f7d2a872bc5de.tar.gz
Merge branch 'feature/2023.07.0'
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD71
-rw-r--r--comma-ide-community.desktop8
-rw-r--r--comma-ide.install27
5 files changed, 81 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afb8739c0a12..6d1b1751007e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = comma-ide-community
pkgdesc = The Integrated Development Environment for Raku (formerly Perl 6).
- pkgver = 2022.07.0
+ pkgver = 2023.07.0
pkgrel = 1
url = https://commaide.com/
- install = comma-ide.install
arch = any
license = APACHE
- depends = java-runtime
- optdepends = rakudo-star
- optdepends = rakudo
- provides = comma-ide
- source = https://commaide.com/download/community/linux
+ source = comma-ide-community-2023.07.0.tar.gz::https://commaide.com/download/community/linux
source = comma-ide-community.desktop
- sha256sums = e812ba0c016995bad9f7c6cc1d736da71d14e69021c9685931f9a446903058f0
- sha256sums = a805e27b65c742889e2d12def48ed0e12fba0e99a32fae6f21724d5b02f7ea46
+ sha256sums = defe67a45a0d348590271806318f76bb6983ae7f28cf2c32621cd52d713ee19f
+ sha256sums = 79770c7c0b602cd07266da5727afd62eb12e01d7de82e588c216bac7419ff971
pkgname = comma-ide-community
+ install = comma-ide.install
+ optdepends = rakudo-star
+ optdepends = rakudo
+ optdepends = comma-ide-community-jre: JetBrains custom JRE (Recommended)
+ optdepends = java-runtime=11: Required if comma-ide-community-jre is not installed
+
+pkgname = comma-ide-community-jre
+ pkgdesc = JBR (Jetbrains Runtime) for Comma IDE - a patched JRE
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00b6e6b9eb66
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!comma-ide.install
+!comma-ide-community.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 7a350ba03407..cd36a7988d01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,60 @@
-# Maintainer: Connor Nuutinen <cnuutinen@outlook.com>
+# Maintainer: Adam Hellberg <adam.hellberg@sharparam.com>
+# Contributor: Connor Nuutinen <cnuutinen@outlook.com>
# Contributor: David Santiago <demanuel@ymail.com>
# Contributor: jokersus <jokersus.cava@gmail.com>
-pkgname=comma-ide-community
-_pkgname=comma-ide
-_binname=comma
+
+pkgbase=comma-ide-community
+pkgname=(comma-ide-community comma-ide-community-jre)
pkgrel=1
-pkgver=2022.07.0
-_tarname=comma-community-${pkgver}
-provides=(${_pkgname})
+pkgver=2023.07.0
pkgdesc='The Integrated Development Environment for Raku (formerly Perl 6).'
arch=('any')
url='https://commaide.com/'
license=('APACHE')
-depends=('java-runtime')
-optdepends=('rakudo-star' 'rakudo')
-source=('https://commaide.com/download/community/linux'
+source=("$pkgbase-$pkgver.tar.gz::https://commaide.com/download/community/linux"
'comma-ide-community.desktop')
-sha256sums=('e812ba0c016995bad9f7c6cc1d736da71d14e69021c9685931f9a446903058f0'
- 'a805e27b65c742889e2d12def48ed0e12fba0e99a32fae6f21724d5b02f7ea46')
-install=comma-ide.install
+sha256sums=('defe67a45a0d348590271806318f76bb6983ae7f28cf2c32621cd52d713ee19f'
+ '79770c7c0b602cd07266da5727afd62eb12e01d7de82e588c216bac7419ff971')
-package() {
- # No direct link, look at source
- tar -xzvf linux
+_binname=comma
+_tarname=comma-community-${pkgver}
+_installdir='/opt'
- install -dm755 "${pkgdir}"/opt/
- install -dm755 "${pkgdir}"/usr/bin/
- install -dm755 "${pkgdir}"/usr/share/applications/
- install -dm755 "${pkgdir}"/usr/share/icons/
+prepare() {
+ rm -rf "$srcdir/jbr"
+ mv "${srcdir}/${_tarname}/jbr" "$srcdir/jbr"
+}
- cp -a "${srcdir}"/${_tarname}/ "${pkgdir}"/opt/${pkgname}
- rm -rf "${pkgdir}"/opt/${pkgname}/jbr
+build() {
+ sed -i "s/Version=/Version=${pkgver}/" "${pkgbase}.desktop"
+ sed -i "s#Exec=#Exec=\"${_installdir}/${pkgbase}/bin/${_binname}.sh\" %f#" "${pkgbase}.desktop"
+ sed -i "s/Icon=/Icon=${pkgbase}/" "${pkgbase}.desktop"
+}
+
+package_comma-ide-community() {
+ optdepends=(
+ 'rakudo-star' 'rakudo'
+ 'comma-ide-community-jre: JetBrains custom JRE (Recommended)'
+ 'java-runtime=11: Required if comma-ide-community-jre is not installed'
+ )
+ install=comma-ide.install
+
+ install -dm755 "${pkgdir}${_installdir}"
+ install -dm755 "${pkgdir}/usr/bin"
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -dm755 "${pkgdir}/usr/share/icons"
+
+ cp -a "${srcdir}/${_tarname}/" "${pkgdir}${_installdir}/${pkgbase}"
+
+ ln -s "${_installdir}/${pkgbase}/bin/comma.sh" "${pkgdir}/usr/bin/${_binname}"
+ install -m644 "${srcdir}/${pkgbase}.desktop" "${pkgdir}/usr/share/applications"
+
+ ln -s "${_installdir}/${pkgbase}/bin/comma.png" "${pkgdir}/usr/share/icons/${pkgbase}.png"
+}
- ln -s /opt/${pkgname}/bin/${_binname}.sh "${pkgdir}"/usr/bin/${_binname}
- install -m644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications/
+package_comma-ide-community-jre() {
+ pkgdesc='JBR (Jetbrains Runtime) for Comma IDE - a patched JRE'
- ln -s /opt/${pkgname}/bin/comma.png ${pkgdir}/usr/share/icons/${pkgname}.png
+ install -dm755 "${pkgdir}${_installdir}/$pkgbase"
+ mv "$srcdir/jbr" "${pkgdir}${_installdir}/$pkgbase"
}
diff --git a/comma-ide-community.desktop b/comma-ide-community.desktop
index 3d4c5ccfc605..b2359d4a6997 100644
--- a/comma-ide-community.desktop
+++ b/comma-ide-community.desktop
@@ -1,11 +1,11 @@
[Desktop Entry]
-Version=1.0
+Version=
Type=Application
-Exec=/usr/bin/comma %f
-Icon=${_pkgname}
+Exec=
+Icon=
Terminal=false
Type=Application
Name=Comma Community Edition
Comment=The Drive to Develop
Categories=Development;IDE;
-StartupWMClass=jetbrains-comma-ce \ No newline at end of file
+StartupWMClass=jetbrains-comma-ce
diff --git a/comma-ide.install b/comma-ide.install
index f8e6e6d58100..0999b01af29f 100644
--- a/comma-ide.install
+++ b/comma-ide.install
@@ -1,30 +1,27 @@
-post_install(){
+post_install() {
+ local comma_ver=${1%%-*}
cat <<EOF
*Notes*
To adjust the value of the JVM heap size, create
- ~/.CommaCT2020.04/comma.vmoptions (or comma64.vmoptions
- if using a 64-bit JDK), and set the -Xms and -Xmx parameters. To see how
- to do this, you can reference the vmoptions file in the bin folder
+ ~/.config/Edument Central Europe/Comma$comma_ver/comma.vmoptions
+ (or comma64.vmoptions if using a 64-bit JDK) and set the -Xms and -Xmx parameters.
+ To see how to do this, you can reference the vmoptions file in the bin folder.
[OPTIONAL] Changing the location of "config" and "system" directories
------------------------------------------------------------------------------
- By default, Comma stores all your settings under the ~/.CommaCT2020.04/config
- directory and uses ~/.CommaCT2020.04/system as a data cache.
- If you want to change these settings,
+ By default, Comma stores all your settings in the
+ ~/.config/Edument Central Europe/Comma$comma_ver directory
+ and uses ~/.local/share/Edument Central Europe/Comma$comma_ver as a data cache.
+ To change the location of these directories:
- 1. Open a console and cd into ~/.CommaCT2020.04/config
+ 1. Open a console and cd into ~/.config/Edument Central Europe/Comma$comma_ver
- 2. Create the file "idea.properties" and open it in an editor. Set the
- idea.system.path and/or idea.config.path variables as desired, for
- example:
+ 2. Create a file idea.properties and set the idea.system.path and idea.config.path variables, for example:
idea.system.path=~/custom/system
idea.config.path=~/custom/config
- 3. Note that we recommend to store data cache ("system" directory) on a disk
- with at least 1GB of free space.
+ NOTE: Store the data cache ("system" directory) on a disk with at least 1 GB of free space.
EOF
-
}
-