summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-07-09 07:57:59 +1000
committerJustin Dray2015-07-09 08:00:15 +1000
commit787698121249354cf3c967bf55896c33a209b791 (patch)
tree9231a230e754006230a2b88bbd1d8c5558239998
downloadaur-787698121249354cf3c967bf55896c33a209b791.tar.gz
Update to: 0.4.5-1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD27
-rw-r--r--command-not-found.install14
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b60117b8192d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = command-not-found
+ pkgdesc = In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh).
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = http://github.com/metti/command-not-found
+ install = command-not-found.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = tdb
+ makedepends = cmake
+ makedepends = git
+ depends = boost-libs
+ depends = tdb
+ depends = libarchive
+ depends = wget
+ source = https://github.com/metti/command-not-found/archive/v0.4.5.zip
+ md5sums = 351ea2f4a1933f408bcb657070c191a4
+
+pkgname = command-not-found
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..181b3460e424
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0ec61efb657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Matthias Maennich <arch@maennich.net>
+pkgname=command-not-found
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh)."
+arch=('i686' 'x86_64')
+url="http://github.com/metti/command-not-found"
+license=('GPL')
+depends=('boost-libs' 'tdb' 'libarchive' 'wget')
+makedepends=('boost' 'tdb' 'cmake' 'git')
+md5sums=('351ea2f4a1933f408bcb657070c191a4')
+install='command-not-found.install'
+source=("https://github.com/metti/command-not-found/archive/v${pkgver}.zip")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cmake -D CMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="" src
+ make
+}
+
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/command-not-found.install b/command-not-found.install
new file mode 100644
index 000000000000..26f49fa50086
--- /dev/null
+++ b/command-not-found.install
@@ -0,0 +1,14 @@
+post_install() {
+ cnf-sync
+}
+
+post_upgrade() {
+ cnf-sync
+}
+
+pre_remove() {
+ rm -rf /var/lib/cnf/*.db
+ rm -rf /var/lib/cnf/*.tdb
+}
+
+# vim:set ts=2 sw=2 et: