summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182022-04-03 14:59:30 +0200
committerLukas18182022-04-03 14:59:30 +0200
commit3b3371a70263c0aab1e43c45b22578787e251fa4 (patch)
treebe4875308f0268be5afc8f475acc0d20788157b2
parent788a994765247b13a85f0904b4da0ef3359a869c (diff)
downloadaur-3b3371a70263c0aab1e43c45b22578787e251fa4.tar.gz
fix missing `/` at path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3660a9cfd84..1c3358fff28e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = commander-wars
pkgdesc = Advance Wars Clone with a lot of additions customizations and modding support
pkgver = 0.22.5.2
- pkgrel = 3
+ pkgrel = 4
epoch = 0
url = https://github.com/Robosturm/Commander_Wars
arch = x86_64
@@ -13,6 +13,8 @@ pkgbase = commander-wars
depends = qt6-wayland
options = !emptydirs
source = https://github.com/Robosturm/Commander_Wars/archive/Beta_22_5_v2.tar.gz
+ source = fix_path.patch::https://github.com/Robosturm/Commander_Wars/commit/2ddd7a7b55d235f18058955ffbf0b264fbfa22f3.patch
sha512sums = 875809aa3c14bc84f642a9315023e373f5638f7d5ba1ba601051cda3c37c1c016d04603ae5ea803dbabcbfd804938bcbb3871668feb61e92a572de28471080d8
+ sha512sums = e1fcf2fb827db0a410bf2c44a7d9e65919fe37ed6f734937cb1420bd699c637160efd8acfa6c0c5bb1fcb1e018cfe96865fff23d59e5e0f24e2d671e3d8c3499
pkgname = commander-wars
diff --git a/PKGBUILD b/PKGBUILD
index 170a68c71b11..bb350a862885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=commander-wars
pkgver=0.22.5.2
_pkgtag="22_5_v2"
_pkgtag="Beta_${_pkgtag//./_}"
-pkgrel=3
+pkgrel=4
epoch=0
pkgdesc="Advance Wars Clone with a lot of additions customizations and modding support"
arch=("$CARCH")
@@ -13,8 +13,10 @@ license=('LGPL3')
options=(!emptydirs)
depends=('qt6-base' 'qt6-multimedia' 'qt6-wayland')
makedepends=('samurai' 'qt6-tools')
-source=("https://github.com/Robosturm/Commander_Wars/archive/$_pkgtag.tar.gz")
-sha512sums=('875809aa3c14bc84f642a9315023e373f5638f7d5ba1ba601051cda3c37c1c016d04603ae5ea803dbabcbfd804938bcbb3871668feb61e92a572de28471080d8')
+source=("https://github.com/Robosturm/Commander_Wars/archive/$_pkgtag.tar.gz"
+ "fix_path.patch::https://github.com/Robosturm/Commander_Wars/commit/2ddd7a7b55d235f18058955ffbf0b264fbfa22f3.patch")
+sha512sums=('875809aa3c14bc84f642a9315023e373f5638f7d5ba1ba601051cda3c37c1c016d04603ae5ea803dbabcbfd804938bcbb3871668feb61e92a572de28471080d8'
+ 'e1fcf2fb827db0a410bf2c44a7d9e65919fe37ed6f734937cb1420bd699c637160efd8acfa6c0c5bb1fcb1e018cfe96865fff23d59e5e0f24e2d671e3d8c3499')
prepare()
{
@@ -22,6 +24,7 @@ prepare()
sed -i "0,/project (Commander_Wars/s/project (Commander_Wars /project ($pkgname /g" CMakeLists.txt #keep using old save files
sed -i "s/commander_wars/$pkgname/g" Commander_Wars.desktop
sed -i '/RPATH/d' CMakeLists.txt #remove insecure RPATH '/../'
+ patch -Np1 -i "$srcdir/fix_path.patch" #fix missing `/` at path
mkdir -p build
}