summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182022-03-21 18:48:03 +0100
committerLukas18182022-03-21 18:48:03 +0100
commit788a994765247b13a85f0904b4da0ef3359a869c (patch)
treec9ff3fc87fdf4861359013ac22280dd453def00c
parent0bbc666a3d84b0d300b4e5a9e90b738516007269 (diff)
downloadaur-788a994765247b13a85f0904b4da0ef3359a869c.tar.gz
fix insecure RPATH
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 569464a31ce8..f3660a9cfd84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = commander-wars
pkgdesc = Advance Wars Clone with a lot of additions customizations and modding support
pkgver = 0.22.5.2
- pkgrel = 2
+ pkgrel = 3
epoch = 0
url = https://github.com/Robosturm/Commander_Wars
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d5190a64b159..170a68c71b11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=commander-wars
pkgver=0.22.5.2
_pkgtag="22_5_v2"
_pkgtag="Beta_${_pkgtag//./_}"
-pkgrel=2
+pkgrel=3
epoch=0
pkgdesc="Advance Wars Clone with a lot of additions customizations and modding support"
arch=("$CARCH")
@@ -21,6 +21,7 @@ prepare()
cd "$srcdir/Commander_Wars-$_pkgtag"
sed -i "0,/project (Commander_Wars/s/project (Commander_Wars /project ($pkgname /g" CMakeLists.txt #keep using old save files
sed -i "s/commander_wars/$pkgname/g" Commander_Wars.desktop
+ sed -i '/RPATH/d' CMakeLists.txt #remove insecure RPATH '/../'
mkdir -p build
}
@@ -44,5 +45,5 @@ package()
DESTDIR="$pkgdir" samu install
echo "remove qt libs"
- rm -rf "$pkgdir/usr/lib" #do not need qt libarys, if the qt packeg is installed; addr2line is not used on linux
+ rm -rf "$pkgdir/usr/lib" #qt libarys are not needed, if the qt package is installed; addr2line binary is not used on linux
}