summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182022-03-21 13:43:40 +0100
committerLukas18182022-03-21 13:43:40 +0100
commitdb74dc3e2485d7140fccf2e5d857835eace7baeb (patch)
tree81720e7c5d38f9623063c293ddb0a6c1728a66a4
parente25f0c017fa165b226e2d2d3d86e6835239eb32e (diff)
downloadaur-db74dc3e2485d7140fccf2e5d857835eace7baeb.tar.gz
update to 0.22.5.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
-rw-r--r--data_location.patch21
3 files changed, 14 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42e35e05a470..b5a1fb28507e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = commander-wars
pkgdesc = Advance Wars Clone with a lot of additions customizations and modding support
- pkgver = 0.22.3.1
+ pkgver = 0.22.5.2
pkgrel = 2
epoch = 0
url = https://github.com/Robosturm/Commander_Wars
@@ -12,11 +12,9 @@ pkgbase = commander-wars
depends = qt6-multimedia
depends = qt6-wayland
options = !emptydirs
- source = https://github.com/Robosturm/Commander_Wars/archive/Beta_22_3_1.tar.gz
+ source = https://github.com/Robosturm/Commander_Wars/archive/Beta_22_5_v2.tar.gz
source = Commander Wars.desktop
- source = data_location.patch
- sha512sums = d025313ba93751c0c641f84ae00bfe7c389b2d61aab97f39c75b9c09977df8830a14f8110b276c92dca789eba5e0050f939aa41de918f90d7954fc1f309c5602
+ sha512sums = 875809aa3c14bc84f642a9315023e373f5638f7d5ba1ba601051cda3c37c1c016d04603ae5ea803dbabcbfd804938bcbb3871668feb61e92a572de28471080d8
sha512sums = 7d670b514cc373423420879433eb72e18eed75ae9b5288b24e47fa3c8d5acd3ca33d86cd53a0992d8a11a6550cfc711a3d6ad37a3ada889bea3d19497e8d9fe7
- sha512sums = 577ecfa46c049443c992fb17e5469451f12ceedfc0056a9805a4e732696dbc2bd79bce1a958d40b05c7f540e4a3a4a764be1c374d9dffdbcd1df54cb4c9652d9
pkgname = commander-wars
diff --git a/PKGBUILD b/PKGBUILD
index 8ae49aea8240..2e42377f9100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Lukas1818 aur at lukas1818 dot de
pkgname=commander-wars
-pkgver=0.22.3.1
-_pkgtag="${pkgver:2}"
+pkgver=0.22.5.2
+_pkgtag="22_5_v2"
_pkgtag="Beta_${_pkgtag//./_}"
pkgrel=2
epoch=0
@@ -14,17 +14,16 @@ options=(!emptydirs)
depends=('qt6-base' 'qt6-multimedia' 'qt6-wayland')
makedepends=('samurai' 'qt6-tools')
source=("https://github.com/Robosturm/Commander_Wars/archive/$_pkgtag.tar.gz"
- "Commander Wars.desktop"
- "data_location.patch")
-sha512sums=('d025313ba93751c0c641f84ae00bfe7c389b2d61aab97f39c75b9c09977df8830a14f8110b276c92dca789eba5e0050f939aa41de918f90d7954fc1f309c5602'
- '7d670b514cc373423420879433eb72e18eed75ae9b5288b24e47fa3c8d5acd3ca33d86cd53a0992d8a11a6550cfc711a3d6ad37a3ada889bea3d19497e8d9fe7'
- '577ecfa46c049443c992fb17e5469451f12ceedfc0056a9805a4e732696dbc2bd79bce1a958d40b05c7f540e4a3a4a764be1c374d9dffdbcd1df54cb4c9652d9')
+ "Commander Wars.desktop")
+sha512sums=('875809aa3c14bc84f642a9315023e373f5638f7d5ba1ba601051cda3c37c1c016d04603ae5ea803dbabcbfd804938bcbb3871668feb61e92a572de28471080d8'
+ '7d670b514cc373423420879433eb72e18eed75ae9b5288b24e47fa3c8d5acd3ca33d86cd53a0992d8a11a6550cfc711a3d6ad37a3ada889bea3d19497e8d9fe7')
prepare()
{
cd "$srcdir/Commander_Wars-$_pkgtag"
+ sed -i "0,/project (Commander_Wars/s/project (Commander_Wars /project ($pkgname /g" CMakeLists.txt #keep using old save files
+ sed -i "s/commander_wars/$pkgname/g" Commander_Wars.desktop
mkdir -p build
- patch -Np1 -i "$srcdir/data_location.patch"
}
build()
@@ -36,7 +35,7 @@ build()
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTING=off
+ -DUSEAPPCONFIGPATH=ON
samu
}
@@ -45,14 +44,7 @@ package()
{
cd "$srcdir/Commander_Wars-$_pkgtag/build"
- DESTDIR="mess" samu install #game does not use the Linux directory structure; Files must move manual to the right place.
-
- cd mess/usr/Commander_Wars*
- mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/$pkgname"
- cp -p "Commander_Wars" "$pkgdir/usr/bin/$pkgname"
- cp -prT "templates/" "$pkgdir/usr/share/$pkgname/"
-
- install -Dm 644 "$srcdir/Commander_Wars-$_pkgtag/icon.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm 755 "$srcdir/Commander Wars.desktop" "$pkgdir/usr/share/applications/Commander Wars.desktop"
+ DESTDIR="$pkgdir" samu install
+ echo "remove qt libs"
+ rm -rf "$pkgdir/usr/lib" #do not need qt libarys, if the qt packeg is installed; addr2line is not used on linux
}
diff --git a/data_location.patch b/data_location.patch
deleted file mode 100644
index 751b38a228f2..000000000000
--- a/data_location.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/coreengine/settings.cpp b/coreengine/settings.cpp
-index ca98e1fe0..60216b482 100644
---- a/coreengine/settings.cpp
-+++ b/coreengine/settings.cpp
-@@ -17,7 +17,7 @@
- #include <QInputDevice>
- #include "3rd_party/oxygine-framework/oxygine-framework.h"
-
--const QString Settings::m_settingFile = "Commander_Wars.ini";
-+const QString Settings::m_settingFile = QStandardPaths::writableLocation(QStandardPaths::AppConfigLocation) + "/Commander_Wars.ini";
- float Settings::m_mouseSensitivity = -0.75f;
- qint32 Settings::m_x = 0;
- qint32 Settings::m_y = 0;
-@@ -178,6 +178,7 @@ Settings::Settings()
- defaultPath = QStandardPaths::writableLocation(QStandardPaths::DocumentsLocation) + "/commander_wars/";
- defaultCoCount = 1;
- }
-+ defaultPath = QStandardPaths::writableLocation(QStandardPaths::AppLocalDataLocation);
- auto devices = QInputDevice::devices();
- bool hasTouch = false;
- for (const auto & device: qAsConst(devices))