summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Mavro2020-09-01 22:17:05 +0200
committerPierre Mavro2020-09-01 22:17:05 +0200
commit642713c7ba17a2c76e2a0fe8250a92f25a38c8ae (patch)
treeda5d578892f8fa56b2c061b6b7d02ac7da35b37f
parentaa3702a9cd5aa9d255624c807d59106d1580c23c (diff)
downloadaur-642713c7ba17a2c76e2a0fe8250a92f25a38c8ae.tar.gz
refactor: follow best practices
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff2be28a6a24..391cc9ad5728 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = commitizen-go
pkgdesc = Command line utility to standardize git commit messages, golang version
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/lintingzhen/commitizen-go
arch = x86_64
license = GPL
makedepends = git
makedepends = go
- makedepends = automake
source = https://github.com/lintingzhen/commitizen-go/archive/v1.0.0.tar.gz
md5sums = b35e8fa0b64b253ee627a4b5fd67b8e0
diff --git a/PKGBUILD b/PKGBUILD
index 0484a3c784a7..0f950a6f36da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Pierre Mavro <deimosfr@gmail.com>
pkgname=commitizen-go
pkgver=1.0.0
-pkgrel=2
+pkgrel=4
pkgdesc="Command line utility to standardize git commit messages, golang version"
arch=(x86_64)
url="https://github.com/lintingzhen/commitizen-go"
license=('GPL')
-makedepends=(git go automake)
+makedepends=(git go)
source=("https://github.com/lintingzhen/commitizen-go/archive/v$pkgver.tar.gz")
build() {
@@ -15,7 +15,8 @@ build() {
}
package() {
+ git_exec_path=$(git --exec-path)
cd "$pkgname-$pkgver"
- sudo make install
+ install -Dm755 "$pkgname" "$pkgdir/$git_exec_path/git-cz"
}
md5sums=('b35e8fa0b64b253ee627a4b5fd67b8e0')