summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Mavro2020-05-25 10:51:12 +0200
committerPierre Mavro2020-05-25 10:51:12 +0200
commitd150ce783202af55da2dfcfb7a4b9467bcd4a77f (patch)
treecbf38fbdfc158927838dbe76cee7fe20589c70ef
downloadaur-d150ce783202af55da2dfcfb7a4b9467bcd4a77f.tar.gz
feat: adding commitizen-go
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82dfc64bb8e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = commitizen-go
+ pkgdesc = Command line utility to standardize git commit messages, golang version
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/lintingzhen/commitizen-go
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = go
+ source = https://github.com/lintingzhen/commitizen-go/archive/v0.1.0.tar.gz
+ md5sums = 89331e0516895e467bc49a1a17e8bb0a
+
+pkgname = commitizen-go
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..03b00208aa97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+src/
+pkg/
+update.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd6ec9141ff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Pierre Mavro <deimosfr@gmail.com>
+pkgname=commitizen-go
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Command line utility to standardize git commit messages, golang version"
+arch=(x86_64)
+url="https://github.com/lintingzhen/commitizen-go"
+license=('GPL')
+makedepends=(git go)
+source=("https://github.com/lintingzhen/commitizen-go/archive/v$pkgver.tar.gz")
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install
+}
+md5sums=('89331e0516895e467bc49a1a17e8bb0a')