summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-03-24 13:58:30 +0100
committerCarl Smedstad2024-03-24 14:10:27 +0100
commit385b6569f8ca5f0e2d3ac71324ef8c4ec4584b68 (patch)
treeb82b9c023a3cffd6ca3725c6b7be35de958dd168
downloadaur-385b6569f8ca5f0e2d3ac71324ef8c4ec4584b68.tar.gz
upgpkg: 19.1.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml3
-rw-r--r--PKGBUILD32
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c407ceb4c8f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = commitlint-config-conventional
+ pkgdesc = Commitlint config enforcing conventional commits
+ pkgver = 19.1.0
+ pkgrel = 1
+ url = https://github.com/conventional-changelog/commitlint
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = commitlint
+ depends = nodejs
+ noextract = commitlint-config-conventional-19.1.0.tgz
+ source = commitlint-config-conventional-19.1.0.tgz::https://registry.npmjs.org/@commitlint/config-conventional/-/config-conventional-19.1.0.tgz
+ sha256sums = 7ade13700dd3f7af4bc0e1a15cf755874420e6662668c5ba8163896fce95a19b
+
+pkgname = commitlint-config-conventional
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0df2b70016b9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.nvchecker.toml
+!.SRCINFO
+!PKGBUILD
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..328dfa5fcb14
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,3 @@
+[commitlint-config-conventional]
+source = "npm"
+npm = "@commitlint/config-conventional"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..472dfc68e774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+
+pkgname=commitlint-config-conventional
+_pkgname=@commitlint/config-conventional
+pkgver=19.1.0
+pkgrel=1
+pkgdesc="Commitlint config enforcing conventional commits"
+arch=(any)
+url="https://github.com/conventional-changelog/commitlint"
+license=(MIT)
+depends=(
+ commitlint
+ nodejs
+)
+makedepends=(npm)
+source=("$pkgname-$pkgver.tgz::https://registry.npmjs.org/$_pkgname/-/config-conventional-$pkgver.tgz")
+noextract=("$pkgname-$pkgver.tgz")
+sha256sums=('7ade13700dd3f7af4bc0e1a15cf755874420e6662668c5ba8163896fce95a19b')
+
+package() {
+ npm install -g \
+ --cache "$srcdir/npm-cache" \
+ --prefix "$pkgdir/usr" \
+ "$srcdir/$pkgname-$pkgver.tgz"
+
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" \
+ "$pkgdir/usr/lib/node_modules/$_pkgname/license.md"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
+}