summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Mendes2023-02-14 19:04:11 -0300
committerPedro Mendes2023-02-14 19:04:11 -0300
commit9bba34e6a5d6d79aa9a1ccadc8fc0d14cc959240 (patch)
tree09a72a284168c86349c79e5f03228f8c76b8dc0d
downloadaur-9bba34e6a5d6d79aa9a1ccadc8fc0d14cc959240.tar.gz
feat: New AUR package of "commit" a command line aplication written in rust
I have changed the of name of the package because already exists one in the AUR named commit, some others packages do this and I think it is fine. I have read all the rules to publish packages to the AUR and I think this program can be useful for a majority of the people.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bba54cfef4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = commits
+ pkgdesc = A tool to make patterned (conventional) commit messages
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://gitub.com/alt-art/commit
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ depends = git
+ source = commits-0.4.1.tar.gz::https://github.com/alt-art/commit/archive/refs/tags/0.4.1.tar.gz
+ sha256sums = 8685f0cd187980f980a7b6f26613bf32983e180eede1e0de09ef5e168b768328
+
+pkgname = commits
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b735fd64869
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Pedro Mendes <pedromendescraft@gmail.com>
+
+pkgname=commits
+_pkgname=commit
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A tool to make patterned (conventional) commit messages"
+arch=('x86_64' 'i686')
+url="https://gitub.com/alt-art/commit"
+license=('MIT')
+depends=('git')
+makedepends=('rust' 'cargo' 'git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/alt-art/$_pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('8685f0cd187980f980a7b6f26613bf32983e180eede1e0de09ef5e168b768328')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ cargo build --release
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ cargo test
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$pkgname"
+}