summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Mullins2016-01-09 20:47:06 -0500
committerChristopher Mullins2016-01-09 20:47:06 -0500
commit404a428bf381e23b41874105331c572e25fe8b22 (patch)
tree6620bd66a8c5a78f8a6c8c3ebef4e191dbcea1bf
downloadaur-404a428bf381e23b41874105331c572e25fe8b22.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..119294afdd8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jan 10 01:44:32 UTC 2016
+pkgbase = commontk-git
+ pkgdesc = A set of common support code for medical imaging, surgical navigation, and related purposes.
+ pkgver = r5007.0f14f50
+ pkgrel = 1
+ url = http://commontk.org
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = cmake
+ makedepends = subversion
+ depends = qt4
+ optdepends = python2: For scripting support
+ source = git://github.com/commontk/CTK.git
+ md5sums = SKIP
+
+pkgname = commontk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9bb23b11d26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chris <christopher.r.mullins g-mail>
+
+pkgname=commontk-git
+pkgrel=1
+pkgdesc='A set of common support code for medical imaging, surgical navigation, and related purposes.'
+pkgver=r5007.0f14f50
+arch=('i686' 'x86_64')
+url='http://commontk.org'
+depends=('qt4')
+makedepends=('git' 'cmake' 'subversion')
+optdepends=('python2: For scripting support')
+license=('Apache')
+source=("git://github.com/commontk/CTK.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd $srcdir/CTK
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir
+ rm -rf build
+ mkdir build
+ cd build
+
+ cmake \
+ -DCTK_SUPERBUILD:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCTK_LIB_Widgets:BOOL=ON \
+ ../CTK
+
+ make
+}
+
+package() {
+ cd $srcdir/build
+ make DESTDIR=${pkgdir} install
+}