summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Brennan2015-11-08 12:20:48 -0500
committerStephen Brennan2015-11-08 12:20:48 -0500
commit272a3986f5ad4e752a7fe0dca81789292ede3b93 (patch)
tree67c6695ddb553a3e6dc01cbea8769fb671b8d264
downloadaur-272a3986f5ad4e752a7fe0dca81789292ede3b93.tar.gz
Initial commit.
-rw-r--r--.INSTALL6
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
3 files changed, 76 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..dce7c88b6706
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,6 @@
+post_install() {
+ xdg-icon-resource forceupdate
+}
+post_remove() {
+ xdg-icon-resource forceupdate
+} \ No newline at end of file
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a11aa40af39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = communi-desktop
+ pkgdesc = An IRC client for desktop environments.
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = https://communi.github.io/
+ install = .INSTALL
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = qt5-x11extras
+ depends = qt5-multimedia
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ depends = libcommuni
+ source = https://github.com/communi/communi-desktop/archive/v3.4.0.tar.gz
+ source = shared.tar.gz::https://github.com/communi/communi-shared/archive/v3.4.0.tar.gz
+ md5sums = 8f05ceb73232a763b4821e53fd6d7317
+ md5sums = 420d3167ddce7a338d803ecc2fa5d03a
+
+pkgname = communi-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba5304120265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Stephen Brennan <smb196@case.edu>
+pkgname=communi-desktop
+pkgver=3.4.0
+pkgrel=1
+epoch=
+pkgdesc="An IRC client for desktop environments."
+arch=('x86_64' 'i686')
+url="https://communi.github.io/"
+license=('GPL')
+groups=()
+depends=('qt5-x11extras' 'qt5-multimedia' 'hicolor-icon-theme' 'xdg-utils' 'libcommuni')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=.INSTALL
+changelog=
+source=("https://github.com/communi/$pkgname/archive/v$pkgver.tar.gz"
+ "shared.tar.gz::https://github.com/communi/communi-shared/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=("8f05ceb73232a763b4821e53fd6d7317"
+ "420d3167ddce7a338d803ecc2fa5d03a")
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ rmdir src/libs/base/shared
+ mv "../communi-shared-$pkgver" src/libs/base/shared
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+}