summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-03-13 08:13:27 +0000
committerxiota2024-03-13 08:13:27 +0000
commit5e067582769a7b9f1d43f3ccf18c2faa148e381e (patch)
tree9d3c44e53f2b4c90e7b633f2083335bbce5a5c19
parent12b408bcd5f0417a09f54aae36c99803eb4a4858 (diff)
downloadaur-5e067582769a7b9f1d43f3ccf18c2faa148e381e.tar.gz
update depends, etc
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD103
3 files changed, 96 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c8123e2d61b..84a2d962c486 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
pkgbase = como
pkgdesc = Library collection to easily create Wayland and X11 compositors
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/winft/como
arch = x86_64
arch = aarch64
- license = LGPL
+ license = LGPL-2.1-only
makedepends = extra-cmake-modules
- depends = qt6-5compat
- depends = qt6-tools
+ makedepends = git
+ makedepends = kdoctools
+ makedepends = ninja
depends = kauth
depends = kconfigwidgets
- depends = kdbusaddons
depends = kdecoration
- depends = kdoctools
- depends = knewstuff
- depends = kscreenlocker
+ depends = kquickcharts
+ depends = libepoxy
+ depends = libqaccessibilityclient-qt6
+ depends = qt6-5compat
+ depends = qt6-declarative
+ depends = qt6-tools
depends = wlroots
depends = wrapland
- optdepends = xorg-xwayland: x11 app support for wayland
provides = kwin
conflicts = kwin
- source = https://github.com/winft/como/archive/refs/tags/v0.1.0.tar.gz
- sha1sums = 22c44272927007ad7f6bb239a01957f2dca63692
+ source = como-0.1.0.tar.gz::https://github.com/winft/como/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 49d9b8b8b8197f4443f8eae71db8adecf51da73c221a4712d0d8cc46b9fdc09f
pkgname = como
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 88adabc0c291..6747bcc647d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,90 @@
-# Author: Roman Gilg <subdiff@gmail.com>
# Maintainer: abelian424
-pkgname=como
+_pkgname="como"
+pkgname="$_pkgname"
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Library collection to easily create Wayland and X11 compositors'
-arch=(x86_64 aarch64)
url="https://github.com/winft/como"
-license=(LGPL)
-depends=(qt6-5compat qt6-tools kauth kconfigwidgets kdbusaddons kdecoration kdoctools knewstuff kscreenlocker wlroots 'wrapland')
-provides=(kwin)
-conflicts=(kwin)
-makedepends=(extra-cmake-modules)
-optdepends=('xorg-xwayland: x11 app support for wayland')
-source=("https://github.com/winft/como/archive/refs/tags/v$pkgver.tar.gz")
-sha1sums=('22c44272927007ad7f6bb239a01957f2dca63692')
-
-prepare() {
- mkdir -p $pkgname
- cd $pkgname
- tar -xvf ../v$pkgver.tar.gz --strip-components=1
-}
+license=('LGPL-2.1-only')
+arch=('x86_64' 'aarch64')
+
+depends=(
+ kauth
+ kconfigwidgets
+ kdecoration
+ kquickcharts
+ libepoxy
+ libqaccessibilityclient-qt6
+ qt6-5compat
+ qt6-declarative
+ qt6-tools
+ wlroots
+
+ # AUR
+ wrapland
+
+ ## implicit
+ #hicolor-icon-theme
+ #kcmutils
+ #kcolorscheme
+ #kconfig
+ #kcoreaddons
+ #kglobalaccel
+ #ki18n
+ #kidletime
+ #kirigami
+ #kpackage
+ #kservice
+ #ksvg
+ #kwidgetsaddons
+ #kwindowsystem
+ #libinput
+ #libplasma
+ #libx11
+ #libxcb
+ #libxkbcommon
+ #qt6-base
+ #wayland
+ #xcb-util-image
+ #xcb-util-keysyms
+)
+makedepends=(
+ extra-cmake-modules
+ git
+ kdoctools
+ ninja
+)
+
+provides=("kwin")
+conflicts=("kwin")
+
+_pkgsrc="$_pkgname-$pkgver"
+_pkgext="tar.gz"
+source=(
+ "$_pkgsrc.$_pkgext"::"$url/archive/refs/tags/v$pkgver.$_pkgext"
+)
+sha256sums=(
+ '49d9b8b8b8197f4443f8eae71db8adecf51da73c221a4712d0d8cc46b9fdc09f'
+)
build() {
- mkdir -p build
- cd build
- cmake ../$pkgname \
- -DCMAKE_BUILD_TYPE=Release
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
+ -G Ninja
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -DCMAKE_INSTALL_LIBDIR='lib'
+ -DCMAKE_INSTALL_LIBEXECDIR="lib/$_pkgname"
+ -DBUILD_TESTING=OFF
+ -Wno-dev
+ )
+
+ cmake "${_cmake_options[@]}"
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}