summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-09 23:04:33 +0100
committerWorMzy Tykashi2015-06-09 23:04:33 +0100
commitd4ab74a8ea09ad3367b79a2e8b532bfee9edc9c4 (patch)
tree43b297e7d3efb4a013c5de2ff9fa2fd797aa3c6a
downloadaur-d4ab74a8ea09ad3367b79a2e8b532bfee9edc9c4.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD67
-rw-r--r--cmdagent.service11
-rw-r--r--cmgdaemon.service11
-rw-r--r--comodo.install42
-rwxr-xr-xcomodo.sh3
6 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ccd7f2d852f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = comodo
+ pkgdesc = An antivirus suite with real-time protection
+ pkgver = 1.1.268025
+ pkgrel = 6
+ url = https://www.comodo.com/
+ install = comodo.install
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = pam
+ depends = glibc
+ depends = qt4
+ depends = gcc-libs
+ optdepends = postfix
+ optdepends = exim
+ optdepends = qmail
+ optdepends = sendmail
+ optdepends = comodo-modules: real-time protection
+ options = !strip
+ source = comodo.sh
+ source = cmdagent.service
+ source = cmgdaemon.service
+ md5sums = cf564cf0421e14d1121eaa7112003c1e
+ md5sums = 372d8c3171424cb9e3ab0797842a7f77
+ md5sums = be4bb222442f2668075dc175cbbe964c
+ source_x86_64 = http://cdn.download.comodo.com/cavmgl/download/installs/1000/standalone/CAV_LINUX-1.1.268025-1.x86_64.rpm
+ md5sums_x86_64 = 555ee6f51d116d2462962a2e4256aeba
+ source_i686 = http://cdn.download.comodo.com/cavmgl/download/installs/1000/standalone/CAV_LINUX-1.1.268025-1.i686.rpm
+ md5sums_i686 = 94c3b08023754ecc09c81be1cc5e7ba0
+
+pkgname = comodo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61347efb5e98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+
+pkgname=comodo
+pkgver=1.1.268025
+_revision=1
+pkgrel=6
+pkgdesc="An antivirus suite with real-time protection"
+arch=('x86_64' 'i686')
+url="https://www.comodo.com/"
+license=('custom')
+#depends=('bzip2' 'expat' 'fontconfig' 'freetype2' 'gcc-libs' 'glib2' 'glibc' 'libdbus' 'libffi'
+# 'libice' 'libpng' 'libsm' 'libutil-linux' 'libx11' 'libxau' 'libxcb' 'libxdmcp'
+# 'libxext' 'libxrender' 'openssl' 'pam' 'pcre' 'qt4' 'zlib')
+depends=('pam' 'glibc' 'qt4' 'gcc-libs')
+optdepends=('postfix'
+ 'exim'
+ 'qmail'
+ 'sendmail'
+ 'comodo-modules: real-time protection')
+options=(!strip)
+install=comodo.install
+source=(comodo.sh
+ cmdagent.service
+ cmgdaemon.service)
+source_x86_64+=("http://cdn.download.comodo.com/cavmgl/download/installs/1000/standalone/CAV_LINUX-${pkgver}-${_revision}.x86_64.rpm")
+source_i686+=("http://cdn.download.comodo.com/cavmgl/download/installs/1000/standalone/CAV_LINUX-${pkgver}-${_revision}.i686.rpm")
+
+md5sums=('cf564cf0421e14d1121eaa7112003c1e'
+ '372d8c3171424cb9e3ab0797842a7f77'
+ 'be4bb222442f2668075dc175cbbe964c')
+md5sums_x86_64+=('555ee6f51d116d2462962a2e4256aeba')
+md5sums_i686+=('94c3b08023754ecc09c81be1cc5e7ba0')
+
+package() {
+ # dump opt files to /opt
+ mv opt "$pkgdir/"
+
+ # don't install to /usr/local
+ mv usr/local "$pkgdir/usr"
+
+ # remove libs provided by dependencies
+ #NOTE: this is not permitted by the license and is therefore disabled
+ #rm -rf "$pkgdir/usr/Trolltech/Qt-4.7.4-Comodo/lib"
+
+ # install profile script to add binaries to PATH
+ install -Dm755 comodo.sh "$pkgdir/etc/profile.d/comodo.sh"
+
+ # install subscriber agreement
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname/"
+ cp "$pkgdir/opt/COMODO/doc/eula_free.txt" "$pkgdir/usr/share/licenses/$pkgname/"
+
+ # install service file
+ install -Dm644 cmdagent.service "$pkgdir/usr/lib/systemd/system/cmdagent.service"
+ install -Dm644 cmgdaemon.service "$pkgdir/usr/lib/systemd/system/cmgdaemon.service"
+
+ # make setup script call systemd service instead of sysvinit script
+ #NOTE: this is not permitted by the license and is therefore disabled
+ #sed -i 's:^sh /opt/COMODO/load_cmdagent\.sh.*:systemctl restart cmdagent:' "$pkgdir/opt/COMODO/post_setup.sh"
+ #sed -i 's:^sh /opt/COMODO/load_cmgdaemon\.sh.*:systemctl restart cmgdaemon:' "$pkgdir/opt/COMODO/post_setup.sh"
+
+ # install .desktop files
+ install -dm755 "$pkgdir/usr/share/applications/"
+ cd "$pkgdir/opt/COMODO/menu/"
+ for file in *.desktop; do
+ cp "$file" "$pkgdir/usr/share/applications/"
+ done
+}
diff --git a/cmdagent.service b/cmdagent.service
new file mode 100644
index 000000000000..367557b8bf46
--- /dev/null
+++ b/cmdagent.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Comodo Antivirus Agent
+After=network.target
+
+[Service]
+Type=forking
+WorkingDirectory=/opt/COMODO
+ExecStart=/opt/COMODO/cmdagent
+
+[Install]
+WantedBy=multi-user.target
diff --git a/cmgdaemon.service b/cmgdaemon.service
new file mode 100644
index 000000000000..44e06f993118
--- /dev/null
+++ b/cmgdaemon.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Comodo Antivirus Daemon
+After=cmdagent.service
+
+[Service]
+Type=forking
+WorkingDirectory=/opt/COMODO
+ExecStart=/opt/COMODO/cmgdaemon
+
+[Install]
+WantedBy=multi-user.target
diff --git a/comodo.install b/comodo.install
new file mode 100644
index 000000000000..771d76e15679
--- /dev/null
+++ b/comodo.install
@@ -0,0 +1,42 @@
+post_install() {
+ _common
+}
+
+_common() {
+ update-desktop-database -q
+ /usr/bin/printf '----------------------------------------------------\n'
+ /usr/bin/printf ' Comodo has been installed to /opt/COMODO.\n'
+ if [[ "$1" != "update" ]]; then
+ /usr/bin/printf ' This directory will be added to your path when you\n'
+ /usr/bin/printf ' next log in (assuming you source /etc/profile.d/*)\n'
+ fi
+ /usr/bin/printf ' Run /opt/COMODO/post_setup.sh as root to configure\n'
+ /usr/bin/printf ' this application.\n'
+ if [[ "$1" != "update" ]]; then
+ /usr/bin/printf '\n'
+ /usr/bin/printf ' After running post_setup, start the cmdagent\n'
+ /usr/bin/printf ' # systemctl start cmdagent.service\n'
+ /usr/bin/printf ' Then run /opt/COMODO/cav as your normal user and\n'
+ /usr/bin/printf ' update your virus definitions\n'
+ /usr/bin/printf '\n'
+ /usr/bin/printf ' Finally, if you want the mail scanner, you need to\n'
+ /usr/bin/printf ' start cmgdaemon.service\n'
+ /usr/bin/printf ' # systemctl start cmgdaemon.service\n'
+ /usr/bin/printf '\n'
+ /usr/bin/printf ' Remember to enable the services you want running\n'
+ fi
+ /usr/bin/printf '----------------------------------------------------\n'
+}
+
+post_remove() {
+ update-desktop-database -q
+ /usr/bin/printf '----------------------------------------------------\n'
+ /usr/bin/printf ' Be aware that you may still have redirfs/avflt\n'
+ /usr/bin/printf ' kernel modules loaded/installed on your system. You\n'
+ /usr/bin/printf ' will need to remove these manually.\n'
+ /usr/bin/printf '----------------------------------------------------\n'
+}
+
+post_upgrade() {
+ _common update
+}
diff --git a/comodo.sh b/comodo.sh
new file mode 100755
index 000000000000..0e0a146b39d5
--- /dev/null
+++ b/comodo.sh
@@ -0,0 +1,3 @@
+PATH=$PATH:/opt/COMODO
+
+export PATH