summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2016-09-08 11:50:42 +0100
committerWorMzy Tykashi2016-09-08 11:50:42 +0100
commit7e84ecce33aac40dec1259c39bb3609ed6064fa5 (patch)
treed8272346b3035c49cbeac9bca090fc16af442cd0
parent4c18fe15b65d9cedc5167c12262fb78d78076606 (diff)
downloadaur-7e84ecce33aac40dec1259c39bb3609ed6064fa5.tar.gz
Updated for 4.7.x linux kernel
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--comodo-modules.install2
-rw-r--r--i_mutex-fix.patch47
4 files changed, 63 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88bf1d85946f..1f6a9bffc9d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = comodo-modules
pkgdesc = Modules for Comodo Antivirus for providing realtime protection
- pkgver = 20150307_4.5.1_1
+ pkgver = 20150307_4.7.2_1
pkgrel = 1
url = http://www.bondoffamily-net.com/~kinta-chan
install = comodo-modules.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = linux-headers>=4.5
- makedepends = linux-headers<4.6
- depends = linux>=4.5
- depends = linux<4.6
+ makedepends = linux-headers>=4.7
+ makedepends = linux-headers<4.8
+ depends = linux>=4.7
+ depends = linux<4.8
depends = comodo
source = driver-20150307.tar::http://www.bondoffamily-net.com/~kinta-chan/techknow/DownLoad/redirfs/beta/driver.tar
+ source = i_mutex-fix.patch
md5sums = bdf595fdb2493def6e6e128f96b83916
+ md5sums = 464a910b54d6b8ad20408bb10131424d
pkgname = comodo-modules
diff --git a/PKGBUILD b/PKGBUILD
index 7e19b5de408a..6ffef4d66f65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
pkgname=comodo-modules
-pkgver=20150307_4.5.1_1
+pkgver=20150307_4.7.2_1
pkgrel=1
pkgdesc="Modules for Comodo Antivirus for providing realtime protection"
arch=('i686' 'x86_64')
url="http://www.bondoffamily-net.com/~kinta-chan"
license=('GPL3')
-depends=('linux>=4.5' 'linux<4.6' 'comodo')
-makedepends=('linux-headers>=4.5' 'linux-headers<4.6')
+depends=('linux>=4.7' 'linux<4.8' 'comodo')
+makedepends=('linux-headers>=4.7' 'linux-headers<4.8')
install=comodo-modules.install
_date=20150307
-source=("driver-${_date}.tar::${url}/techknow/DownLoad/redirfs/beta/driver.tar")
-md5sums=('bdf595fdb2493def6e6e128f96b83916')
+source=("driver-${_date}.tar::${url}/techknow/DownLoad/redirfs/beta/driver.tar"
+ 'i_mutex-fix.patch')
+md5sums=('bdf595fdb2493def6e6e128f96b83916'
+ '464a910b54d6b8ad20408bb10131424d')
pkgver() {
_ver=$(pacman -Q linux | cut -d " " -f 2)
@@ -25,6 +27,7 @@ prepare() {
_ver=$(pacman -Q linux | cut -d " " -f 2)
_kernel=$_ver-ARCH
sed -i "s:\`uname -r\`:${_kernel}:g" Makefile
+ patch -p1 -i "$srcdir/i_mutex-fix.patch"
}
build() {
diff --git a/comodo-modules.install b/comodo-modules.install
index bb0e65bef53b..7ee0e817bf17 100644
--- a/comodo-modules.install
+++ b/comodo-modules.install
@@ -1,5 +1,5 @@
run_depmod() {
- KERNEL=4.4.1-1-ARCH
+ KERNEL=4.7.2-1-ARCH
depmod $KERNEL
}
diff --git a/i_mutex-fix.patch b/i_mutex-fix.patch
new file mode 100644
index 000000000000..8057f061918c
--- /dev/null
+++ b/i_mutex-fix.patch
@@ -0,0 +1,47 @@
+diff -aur a/redirfs/rfs.h b/redirfs/rfs.h
+--- a/redirfs/rfs.h 2016-09-08 11:19:33.782302808 +0100
++++ b/redirfs/rfs.h 2016-09-08 11:39:40.808414921 +0100
+@@ -124,11 +124,11 @@
+
+ inline static void rfs_inode_mutex_lock(struct inode *inode)
+ {
+- mutex_lock(&inode->i_mutex);
++ inode_lock(inode);
+ }
+ inline static void rfs_inode_mutex_unlock(struct inode *inode)
+ {
+- mutex_unlock(&inode->i_mutex);
++ inode_unlock(inode);
+ }
+ #else
+ #define rfs_mutex_t mutex
+@@ -140,11 +140,11 @@
+
+ inline static void rfs_inode_mutex_lock(struct inode *inode)
+ {
+- mutex_lock(&inode->i_mutex);
++ inode_lock(inode);
+ }
+ inline static void rfs_inode_mutex_unlock(struct inode *inode)
+ {
+- mutex_unlock(&inode->i_mutex);
++ inode_unlock(inode);
+ }
+ #endif
+
+diff -aur a/redirfs/rfs_dcache.c b/redirfs/rfs_dcache.c
+--- a/redirfs/rfs_dcache.c 2016-09-08 11:29:37.711005419 +0100
++++ b/redirfs/rfs_dcache.c 2016-09-08 11:39:43.121757790 +0100
+@@ -138,10 +138,10 @@
+ rv = rfs_dcache_get_subs(dir, sibs);
+ rfs_inode_mutex_unlock(dir->d_inode);
+ #else
+- lock = mutex_trylock(&dir->d_inode->i_mutex);
++ lock = inode_trylock(dir->d_inode);
+ rv = rfs_dcache_get_subs(dir, sibs);
+ if (lock)
+- mutex_unlock(&dir->d_inode->i_mutex);
++ inode_unlock(dir->d_inode);
+ #endif
+
+ return rv;