summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2016-01-11 12:11:33 +0000
committerWorMzy Tykashi2016-01-11 12:11:33 +0000
commitb664eb1765d02cfa5d308f58b553ef3afb86d1ad (patch)
treed909f1d6f2d200461477c87e318a7718f490bced
parent1f03b2a7c46f1b02cef72896b006a57166aa65a9 (diff)
downloadaur-b664eb1765d02cfa5d308f58b553ef3afb86d1ad.tar.gz
Updated for 4.3 kernels, fixed install file
-rw-r--r--PKGBUILD8
-rw-r--r--comodo-modules.install2
2 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59d5cd0476bf..6c6aa3a3cccd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
pkgname=comodo-modules
-pkgver=20150307_4.2.2_1
+pkgver=20150307_4.3.3_2
pkgrel=1
pkgdesc="Modules for Comodo Antivirus for providing realtime protection"
arch=('i686' 'x86_64')
url="http://www.bondoffamily-net.com/~kinta-chan"
license=('GPL3')
-depends=('linux>=4.2' 'linux<4.3' 'comodo')
-makedepends=('linux-headers>=4.2' 'linux-headers<4.3')
+depends=('linux>=4.3' 'linux<4.4' 'comodo')
+makedepends=('linux-headers>=4.3' 'linux-headers<4.4')
install=comodo-modules.install
_date=20150307
source=("driver-${_date}.tar::${url}/techknow/DownLoad/redirfs/beta/driver.tar")
@@ -37,5 +37,7 @@ package() {
ROOT_PATH="$srcdir/driver" make INSTALL_MOD_PATH="$pkgdir/usr" install
# fix .install file
+ _ver=$(pacman -Q linux | cut -d " " -f 2)
+ _kernel=$_ver-ARCH
sed -i "s:KERNEL=.*:KERNEL=${_kernel}:" "${startdir}/comodo-modules.install"
}
diff --git a/comodo-modules.install b/comodo-modules.install
index 7bd3b7bfffa6..e188d2f3a1df 100644
--- a/comodo-modules.install
+++ b/comodo-modules.install
@@ -1,5 +1,5 @@
run_depmod() {
- KERNEL=
+ KERNEL=4.3.3-2-ARCH
depmod $KERNEL
}