summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJenny Danzmayr2025-02-07 00:46:31 +0100
committerJenny Danzmayr2025-02-07 00:46:31 +0100
commit6a36c771f82203d8d31a46865df51d494cb63341 (patch)
tree3c90bfc716bd7c5c52e8c3345d5462b465f415aa
parent36927d9e5986e1a032e1d125e94ef7a90e777c1c (diff)
downloadaur-6a36c771f82203d8d31a46865df51d494cb63341.tar.gz
Update to v3.5.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5d7225e03fa..e30fdaccd8ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = companion
pkgdesc = Control software for the Elgato Streamdeck with a focus on broadcasting.
- pkgver = 3.4.4
+ pkgver = 3.5.1
pkgrel = 1
url = https://github.com/bitfocus/companion
install = companion.install
@@ -16,9 +16,9 @@ pkgbase = companion
depends = nss
depends = hicolor-icon-theme
depends = libusb
- source = companion-3.4.4::git+https://github.com/bitfocus/companion.git#tag=v3.4.4
+ source = companion-3.5.1::git+https://github.com/bitfocus/companion.git#tag=v3.5.1
source = bitfocus-companion.desktop
- sha256sums = 04d428940752a4f475f6b357f3ff45919f41923761c33bad8df87553fab7c70b
+ sha256sums = 113ecdcd740674f1d0c2146029ebc42dae2fdf61433453085369cdf3fa1b24b3
sha256sums = 65289895360dae94dd710e6804709c1e3f95e6bc275b1621cb88eb8a7cbd348f
pkgname = companion
diff --git a/PKGBUILD b/PKGBUILD
index c347fdf08fb7..8cc6b65bdafa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=companion
-pkgver=3.4.4
+pkgver=3.5.1
pkgrel=1
pkgdesc="Control software for the Elgato Streamdeck with a focus on broadcasting."
arch=('x86_64' 'aarch64')
@@ -8,12 +8,12 @@ license=('custom')
depends=('gtk3' 'alsa-lib' 'nss' 'hicolor-icon-theme' 'libusb')
makedepends=('nvm' 'git' 'zip' 'python>=3.10.0')
install=companion.install
-_node_version="18.20.4"
+_node_version="22"
source=("${pkgname}-${pkgver}::git+https://github.com/bitfocus/companion.git#tag=v${pkgver}"
"bitfocus-companion.desktop")
-sha256sums=('04d428940752a4f475f6b357f3ff45919f41923761c33bad8df87553fab7c70b'
+sha256sums=('113ecdcd740674f1d0c2146029ebc42dae2fdf61433453085369cdf3fa1b24b3'
'65289895360dae94dd710e6804709c1e3f95e6bc275b1621cb88eb8a7cbd348f')
_ensure_local_nvm() {
@@ -49,6 +49,8 @@ prepare() {
# Enable corepack
corepack enable
+
+ yarn --immutable
}
build() {
@@ -58,8 +60,6 @@ build() {
rm -rf electron-output
- CI=1 ./tools/yarn.sh
-
yarn run dist
}