summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Boer2023-06-05 15:02:38 +0200
committerMaarten de Boer2023-06-05 15:03:36 +0200
commitc809f3b97fde77c1e377d625b8ce34c6db55a977 (patch)
tree6d3c8d87b7aa0352cba510a27eb985e82494549a
parent4ab7cb96d09c2a6e222f38a68663eb90bfacec65 (diff)
downloadaur-c809f3b97fde77c1e377d625b8ce34c6db55a977.tar.gz
Update to 2.4.2 and fix python deps
-rw-r--r--.SRCINFO11
-rw-r--r--50-bitfocus-companion.rules2
-rw-r--r--PKGBUILD12
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64bbbcee48fe..c4db685735bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = companion
pkgdesc = Control software for the Elgato Streamdeck with a focus on broadcasting.
- pkgver = 2.4.1
+ pkgver = 2.4.2
pkgrel = 1
url = https://github.com/bitfocus/companion
install = companion.install
@@ -10,14 +10,17 @@ pkgbase = companion
makedepends = nvm
makedepends = git
makedepends = zip
+ makedepends = python>=3.10.0
+ makedepends = python<3.11.0
depends = gtk3
depends = alsa-lib
depends = nss
- source = companion-2.4.1.tar.gz::https://github.com/bitfocus/companion/archive/refs/tags/v2.4.1.tar.gz
+ depends = hicolor-icon-theme
+ source = companion-2.4.2.tar.gz::https://github.com/bitfocus/companion/archive/refs/tags/v2.4.2.tar.gz
source = 50-bitfocus-companion.rules
source = bitfocus-companion.desktop
- sha256sums = 004fd0fa5ab44f42fe6f5ed260771f830633cb5a579d635767957cd126122a09
- sha256sums = c0e7cd1f730a7b4381e654b53f6fdd1c06911b2593bdfe07bba5e198fc61d5d9
+ sha256sums = ed6c944a5188eda06ba57b0d85149308957ddf7a4cde0a2a6d3c8c49d2206a26
+ sha256sums = dd9121aeecb8b8b72e8a5c1170925e4a62ea4f95ec3d2c46c7c9626b451b9adf
sha256sums = 65289895360dae94dd710e6804709c1e3f95e6bc275b1621cb88eb8a7cbd348f
pkgname = companion
diff --git a/50-bitfocus-companion.rules b/50-bitfocus-companion.rules
index 6d061709342d..ce85e6a691d9 100644
--- a/50-bitfocus-companion.rules
+++ b/50-bitfocus-companion.rules
@@ -9,5 +9,7 @@ SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006c", MODE:="666"
KERNEL=="hidraw", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006c", MODE:="666", GROUP="plugdev"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006d", MODE:="666", GROUP="plugdev"
KERNEL=="hidraw", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006d", MODE:="666", GROUP="plugdev"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0080", MODE:="666", GROUP="plugdev"
+KERNEL=="hidraw", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0080", MODE:="666", GROUP="plugdev"
SUBSYSTEM=="usb", ATTRS{idVendor}=="ffff", ATTRS{idProduct}=="1f41", MODE:="666", GROUP="plugdev"
KERNEL=="hidraw", ATTRS{idVendor}=="ffff", ATTRS{idProduct}=="1f41", MODE:="666", GROUP="plugdev" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6538398c7a07..fca7d1fe2194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
pkgname=companion
-pkgver=2.4.1
+pkgver=2.4.2
pkgrel=1
pkgdesc="Control software for the Elgato Streamdeck with a focus on broadcasting."
arch=('i386' 'x86_64')
url="https://github.com/bitfocus/companion"
license=('custom')
-depends=('gtk3' 'alsa-lib' 'nss')
-makedepends=('nvm' 'git' 'zip')
+depends=('gtk3' 'alsa-lib' 'nss' 'hicolor-icon-theme')
+makedepends=('nvm' 'git' 'zip' 'python>=3.10.0' 'python<3.11.0')
install=companion.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bitfocus/companion/archive/refs/tags/v${pkgver}.tar.gz"
"50-bitfocus-companion.rules"
"bitfocus-companion.desktop")
-sha256sums=('004fd0fa5ab44f42fe6f5ed260771f830633cb5a579d635767957cd126122a09'
- 'c0e7cd1f730a7b4381e654b53f6fdd1c06911b2593bdfe07bba5e198fc61d5d9'
+sha256sums=('ed6c944a5188eda06ba57b0d85149308957ddf7a4cde0a2a6d3c8c49d2206a26'
+ 'dd9121aeecb8b8b72e8a5c1170925e4a62ea4f95ec3d2c46c7c9626b451b9adf'
'65289895360dae94dd710e6804709c1e3f95e6bc275b1621cb88eb8a7cbd348f')
_ensure_local_nvm() {
@@ -44,6 +44,8 @@ prepare() {
nvm install
npm config set cache "${srcdir}/npm"
+ npm config set python python3.10
+ npm config set scripts-prepend-node-path auto
npm install -g node-gyp
npm install -g yarn
}