summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllusive2023-11-15 15:41:21 +1100
committerAllusive2023-11-15 15:41:21 +1100
commit0cb13a9f84f7b2a0484253d07a19e299c5764464 (patch)
tree302d61aa410f0c67597918ef507e360492c4a137
downloadaur-0cb13a9f84f7b2a0484253d07a19e299c5764464.tar.gz
initial commit at 1.6.0
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD33
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8208c5f9e61b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = compfy
+ pkgdesc = A Better Alternative to Picom. With Animations and Active Support
+ pkgver = 1.6.0
+ pkgrel = 2
+ url = https://github.com/allusive-dev/compfy
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = MPL2
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = gcc
+ makedepends = uthash
+ depends = libconfig
+ depends = libev
+ depends = libxdg-basedir
+ depends = pcre2
+ depends = pixman
+ depends = xcb-util-image
+ depends = xcb-util-renderutil
+ depends = libglvnd
+ depends = libx11
+ depends = libxcb
+ depends = libdbus
+ optdepends = dbus: To control Compfy via D-Bus
+ provides = compton
+ provides = compton-git
+ provides = picom
+ provides = picom-git
+ conflicts = compton
+ conflicts = compton-git
+ conflicts = picom
+ conflicts = picom-git
+ source = compfy::git+https://github.com/allusive-dev/compfy.git#tag=1.6.0
+ md5sums = SKIP
+
+pkgname = compfy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98eb5f0d5c69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+_gitfolder=compfy
+_gitname=compfy
+pkgname=compfy
+pkgver=1.6.0
+pkgrel=2
+pkgdesc="A Better Alternative to Picom. With Animations and Active Support"
+arch=(i686 x86_64)
+url="https://github.com/allusive-dev/compfy"
+license=('MIT' 'MPL2')
+depends=('libconfig' 'libev' 'libxdg-basedir' 'pcre2' 'pixman' 'xcb-util-image' 'xcb-util-renderutil' 'libglvnd' 'libx11' 'libxcb' 'libdbus')
+makedepends=('git' 'meson' 'ninja' 'gcc' 'uthash')
+optdepends=('dbus: To control Compfy via D-Bus')
+provides=('compton' 'compton-git' 'picom' 'picom-git')
+conflicts=('compton' 'compton-git' 'picom' 'picom-git')
+source=("${_gitfolder}::git+https://github.com/allusive-dev/compfy.git#tag=${pkgver}")
+md5sums=('SKIP')
+build() {
+ cd "${srcdir}/${_gitfolder}"
+ meson setup --buildtype=release . build
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}/${_gitfolder}"
+ DESTDIR="$pkgdir/" ninja -C build install
+
+ # install license
+ install -D -m644 "LICENSES/MIT" "${pkgdir}/usr/share/licenses/${pkgname/-git$/}/LICENSE-MIT"
+
+ # example conf
+ install -D -m644 "compfy.sample.conf" "${pkgdir}/etc/xdg/compfy.conf.example"
+
+}