summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-12-05 15:45:07 +0100
committerDoron Behar2018-12-05 15:45:07 +0100
commit706d8eea4d18dbe3a4d90df56b7451ec87f9f6dc (patch)
tree577d0f707cc88635ec8a920228fa253a6534372a
downloadaur-706d8eea4d18dbe3a4d90df56b7451ec87f9f6dc.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ddc2d95544e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = compiledb
+ pkgdesc = Tool for generating Clang's JSON Compilation Database file for GNU make-based build systems
+ pkgver = 0.9.8
+ pkgrel = 1
+ url = https://github.com/nickdiego/compiledb-generator
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = python-click
+ depends = python-bashlex
+ replaces = compiledb-generator
+ options = !emptydirs
+ source = https://github.com/nickdiego/compiledb-generator/archive/v0.9.8.tar.gz
+ md5sums = 79a001db1b4a3c98e6ad12d8a6b43347
+
+pkgname = compiledb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a223e98317e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Doron Behar <doron.behar@gmail.com>
+
+pkgname=compiledb
+pkgver=0.9.8
+pkgrel=1
+pkgdesc="Tool for generating Clang's JSON Compilation Database file for GNU make-based build systems"
+arch=('i686' 'x86_64')
+url="https://github.com/nickdiego/compiledb-generator"
+license=('GPL3')
+depends=('python' 'python-click' 'python-bashlex')
+makedepends=()
+provides=()
+conflicts=()
+replaces=(compiledb-generator)
+backup=()
+options=(!emptydirs)
+install=
+source=(${url}/archive/v${pkgver}.tar.gz)
+md5sums=('79a001db1b4a3c98e6ad12d8a6b43347')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}