summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-04-30 00:11:42 +0200
committerLW-archlinux2019-04-30 00:11:42 +0200
commitf6650002cd694a7c03bd1ad18b204a73c881e3de (patch)
tree7ed37040e495989c7d0c515a0079c0673d532955
parenta9a95c0aad43fa25cadaa3c1b78328e5b4f34a92 (diff)
downloadaur-f6650002cd694a7c03bd1ad18b204a73c881e3de.tar.gz
uses ninjaflags instead of makeflags, provides compiler-rt/compiler-rt-git again but with a specific version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d5b0bff6f55..1dcff7201982 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compiler-rt-lw-git
pkgdesc = Compiler runtime libraries for clang
- pkgver = 9.0.0_r315148.03c4e2663ce
+ pkgver = 9.0.0_r315265.6c9f6fd11b6
pkgrel = 1
url = https://compiler-rt.llvm.org/
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = compiler-rt-lw-git
makedepends_x86_64 = lib32-gcc-libs
pkgname = compiler-rt-lw-git
- provides = compiler-rt-git
+ provides = compiler-rt=9.0.0_r315265.6c9f6fd11b6-1
+ provides = compiler-rt-git=9.0.0_r315265.6c9f6fd11b6-1
conflicts = compiler-rt
diff --git a/PKGBUILD b/PKGBUILD
index 1e8374128d24..eedfd9c2791c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@
# Contributor: Tomas Wilhelmsson <tomas.wilhelmsson@gmail.com>
pkgname=compiler-rt-lw-git
-pkgver=9.0.0_r315148.03c4e2663ce
+pkgver=9.0.0_r315265.6c9f6fd11b6
pkgrel=1
pkgdesc="Compiler runtime libraries for clang"
arch=('x86_64')
@@ -54,16 +54,16 @@ build() {
cmake "$srcdir"/llvm-project/compiler-rt/ -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
- if [[ ! $MAKEFLAGS ]]; then
+ if [[ ! $NINJAFLAGS ]]; then
ninja
else
- ninja "$MAKEFLAGS"
+ ninja "$NINJAFLAGS"
fi
}
package() {
conflicts=('compiler-rt')
- provides=('compiler-rt-git')
+ provides=(compiler-rt=$pkgver-$pkgrel compiler-rt-git=$pkgver-$pkgrel)
cd _build