summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-07-04 20:02:18 -0700
committerxiota2023-07-04 20:02:18 -0700
commit56784652dc57c14107e97d64ec55244a62c3ff06 (patch)
tree6fe3df65816afe344a72037238723ad60e0524dd
parente36b681ed2dd12892b04588d408ac6dd2043da23 (diff)
downloadaur-56784652dc57c14107e97d64ec55244a62c3ff06.tar.gz
Build with C++17
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a263676d506..63c1290163f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.14.2
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
@@ -10,19 +10,19 @@ pkgbase = compiz
license = MIT
makedepends = boost
makedepends = cmake
- makedepends = intltool
makedepends = cython
+ makedepends = intltool
depends = boost-libs
- depends = xorg-server
depends = fuse2
depends = glibmm
- depends = libwnck3
- depends = python-gobject
- depends = python-cairo
- depends = protobuf
- depends = metacity
depends = glu
+ depends = libwnck3
depends = libxslt
+ depends = metacity
+ depends = protobuf
+ depends = python-cairo
+ depends = python-gobject
+ depends = xorg-server
optdepends = xorg-xprop: grab various window properties for use in window matching rules
provides = ccsm=0.9.14.2
provides = compiz-bcop=0.9.14.2
diff --git a/PKGBUILD b/PKGBUILD
index 9329166ecb9d..81c631d340eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,29 +8,29 @@
pkgname=compiz
pkgver=0.9.14.2
-pkgrel=2
+pkgrel=3
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
license=('GPL' 'LGPL' 'MIT')
depends=(
'boost-libs'
- 'xorg-server'
'fuse2'
'glibmm'
- 'libwnck3'
- 'python-gobject'
- 'python-cairo'
- 'protobuf'
- 'metacity'
'glu'
+ 'libwnck3'
'libxslt'
+ 'metacity'
+ 'protobuf'
+ 'python-cairo'
+ 'python-gobject'
+ 'xorg-server'
)
makedepends=(
'boost'
'cmake'
- 'intltool'
'cython'
+ 'intltool'
)
optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
@@ -100,6 +100,7 @@ build() {
cd build
cmake .. \
+ -DCMAKE_CXX_STANDARD=17 \
-DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="/usr/lib" \