summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-04-12 11:42:35 -0700
committerShadowKyogre2016-04-12 11:42:35 -0700
commitb52f4b863083b29fc1b12d7544c8d252589a70a8 (patch)
tree907d25a524548a4d7048b8fbc74c66fa135bd812
parent40ddf1c677d6e8999e1c931a0c117f4416e1aa68 (diff)
downloadaur-b52f4b863083b29fc1b12d7544c8d252589a70a8.tar.gz
Update to new style PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7af63548ef73..3981d6656317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Apr 12 18:42:27 UTC 2016
pkgbase = compiz-alone-utils-git
pkgdesc = A few Compiz Standalone utilities based off of some scripts that come with Openbox.
- pkgver = 20110403
+ pkgver = r3.8ac2684
pkgrel = 1
url = https://github.com/ShadowKyogre/Compiz-Standalone-Utils
install = compiz-alone-utils.install
@@ -9,6 +11,8 @@ pkgbase = compiz-alone-utils-git
makedepends = git
optdepends = pyxdg: for the xdg-autostart script
conflicts = compiz-alone-utils
+ source = CompizSAUtils::git://github.com/ShadowKyogre/Compiz-Standalone-Utils.git
+ sha256sums = SKIP
pkgname = compiz-alone-utils-git
diff --git a/PKGBUILD b/PKGBUILD
index cd942e48d88a..c69467675981 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Sapphira Armageddos <shadowkyogre@aim.com>
pkgname=compiz-alone-utils-git
-pkgver=20110403
+pkgver=r3.8ac2684
pkgrel=1
pkgdesc="A few Compiz Standalone utilities based off of some scripts that come with Openbox."
arch=('any')
@@ -12,29 +12,25 @@ optdepends=('pyxdg: for the xdg-autostart script')
makedepends=('git')
install=${pkgname%-git}.install
-_giturl=git://github.com/ShadowKyogre/Compiz-Standalone-Utils.git
_gitname="CompizSAUtils"
+source=(
+ "${_gitname}::git://github.com/ShadowKyogre/Compiz-Standalone-Utils.git"
+)
+
# trick re-determining the build revision and, or entertain the hidden
# makepkg option --forcever, huh
-if [ -z "${FORCE_VER}" ]; then
- msg "Determining latest build revision..."
- FORCE_VER=$(date +%Y%m%d)
-fi
-
+pkgver() {
+ cd "${srcdir}/${_gitname}"
-build() {
- cd "$srcdir"
- if [ -d $_gitname ];then
- cd $_gitname && git pull origin
- else
- git clone $_giturl $_gitname
- fi
+ # currently don't have any tags atm
+ #git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${srcdir}/$_gitname
+ cd "${srcdir}/${_gitname}"
mkdir -p ${pkgdir}/usr/bin
mkdir -p ${pkgdir}/{usr/share/xs,etc/X11/s}essions
@@ -49,3 +45,6 @@ package() {
# vim:set ts=2 sw=2 et:
+sha256sums=(
+ 'SKIP'
+)