summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-09-05 11:25:57 +0100
committerCharles Bos2015-09-05 11:25:57 +0100
commitda4e62793bc64fb4a7f2074d10f57ee39bd51614 (patch)
tree3fe0077d1188b28c492ea0cc71430d6ae21e87d8
parent781f9742a5381635af117f3eb91f7da350b1e383 (diff)
downloadaur-da4e62793bc64fb4a7f2074d10f57ee39bd51614.tar.gz
remove gwd patch. cosmetic pkgbuild fixes.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--set-gwd-default.patch12
3 files changed, 9 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01a1c7cf324e..d81fddaebb14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz-bzr
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)
pkgver = 3971
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/compiz
install = compiz-bzr.install
arch = i686
@@ -38,11 +38,9 @@ pkgbase = compiz-bzr
conflicts = compiz
replaces = compiz-core-bzr
source = compiz::bzr+http://bazaar.launchpad.net/~compiz-team/compiz/0.9.12/
- source = set-gwd-default.patch
source = focus-prevention-disable.patch
source = gtk-extents.patch
sha256sums = SKIP
- sha256sums = 3aa6cb70f357b3d34d51735f4b5bcb0479086d7c7336de4bd8157569d6c52c08
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
diff --git a/PKGBUILD b/PKGBUILD
index 510d38d616a7..38151b516ff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=compiz-bzr
pkgver=3971
-pkgrel=1
+pkgrel=2
_bzrname=compiz
_bzrbranch=0.9.12
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)"
@@ -20,29 +20,28 @@ conflicts=('compiz-core' 'compiz')
provides=("compiz=$_bzrbranch")
replaces=('compiz-core-bzr')
source=("$_bzrname::bzr+http://bazaar.launchpad.net/~compiz-team/$_bzrname/$_bzrbranch/"
- "set-gwd-default.patch"
"focus-prevention-disable.patch"
"gtk-extents.patch")
sha256sums=('SKIP'
- '3aa6cb70f357b3d34d51735f4b5bcb0479086d7c7336de4bd8157569d6c52c08'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9')
install='compiz-bzr.install'
pkgver() {
- cd $_bzrname
+ cd "${_bzrname}"
bzr revno
}
prepare() {
- cd $_bzrname
+ cd "${_bzrname}"
- # Set gtk-window-decorator as default in the Window Decoration plugin
- patch -Np1 -i "${srcdir}/set-gwd-default.patch"
+ # Fix decorator start command
+ sed -i 's/exec \\"${COMPIZ_BIN_PATH}compiz-decorator\\"/\/usr\/bin\/compiz-decorator/g' plugins/decor/decor.xml.in
# Set focus prevention level to off which means that new windows will always get focus
patch -Np1 -i "${srcdir}/focus-prevention-disable.patch"
+ # Use Python 2
find -type f \( -name 'CMakeLists.txt' -or -name '*.cmake' \) -exec sed -e 's/COMMAND python/COMMAND python2/g' -i {} \;
find compizconfig/ccsm -type f -exec sed -e 's|^#!.*python|#!/usr/bin/env python2|g' -i {} \;
@@ -54,7 +53,7 @@ prepare() {
}
build() {
- cd $_bzrname
+ cd "${_bzrname}"
export PYTHON="/usr/bin/python2"
@@ -82,7 +81,7 @@ build() {
}
package() {
- cd $_bzrname/build
+ cd "${_bzrname}/build"
make DESTDIR="${pkgdir}" install
# findcompiz_install needs COMPIZ_DESTDIR and install needs DESTDIR
diff --git a/set-gwd-default.patch b/set-gwd-default.patch
deleted file mode 100644
index 624cffbdd5f5..000000000000
--- a/set-gwd-default.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur original/plugins/decor/decor.xml.in modified/plugins/decor/decor.xml.in
---- original/plugins/decor/decor.xml.in 2013-07-23 20:58:03.000000000 +0100
-+++ modified/plugins/decor/decor.xml.in 2014-06-11 00:01:50.332286339 +0100
-@@ -101,7 +101,7 @@
- <option name="command" type="string">
- <_short>Command</_short>
- <_long>Decorator command line that is executed if no decorator is already running.</_long>
-- <default>exec \"${COMPIZ_BIN_PATH}compiz-decorator\"</default>
-+ <default>gtk-window-decorator</default>
- </option>
- <option name="mipmap" type="bool">
- <_short>Mipmap</_short>