summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2018-08-06 22:12:35 +0100
committerCharles Bos2018-08-06 22:12:35 +0100
commitfdc6a322c0a98abc0dea071205307ad903d98ac2 (patch)
treeedb76d8c726644f88d35a95a661e8253b8a10098
parent8822303e5370799e534e3edd250b05ed52077231 (diff)
downloadaur-fdc6a322c0a98abc0dea071205307ad903d98ac2.tar.gz
Update reverse-unity-config.patch for newer src, add makedep cython2 and add dep python2-gobject
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--reverse-unity-config.patch68
3 files changed, 43 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 085576cb8d6f..6b8481ebbec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compiz-bzr
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)
- pkgver = 4143
+ pkgver = 4182
pkgrel = 1
url = https://launchpad.net/compiz
arch = i686
@@ -11,6 +11,7 @@ pkgbase = compiz-bzr
makedepends = cmake
makedepends = bzr
makedepends = intltool
+ makedepends = cython2
depends = boost
depends = xorg-server
depends = libxcomposite
@@ -31,6 +32,7 @@ pkgbase = compiz-bzr
depends = glu
depends = libsm
depends = dconf
+ depends = python2-gobject
optdepends = xorg-xprop: grab various window properties for use in window matching rules
provides = compiz=0.9.13
provides = compiz-core=0.9.13
@@ -59,7 +61,7 @@ pkgbase = compiz-bzr
sha256sums = SKIP
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
- sha256sums = 5da38bf4f7fd127a01ce9c68ab66d21fe69086228051073896d3d59c6bc400e8
+ sha256sums = fba56d3e5fc8d1b47be2b8eaa6d79f48635daccc26db9b0b88fa281cc50c635e
sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
pkgname = compiz-bzr
diff --git a/PKGBUILD b/PKGBUILD
index bf739af87143..4ab6bafcbf6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Iven Hsu <ivenvd AT gmail>
pkgname=compiz-bzr
-pkgver=4143
+pkgver=4182
pkgrel=1
_bzrname=compiz
_bzrbranch=0.9.13
@@ -11,8 +11,8 @@ pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (development
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
license=('GPL' 'LGPL' 'MIT')
-depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'pygtk' 'desktop-file-utils' 'pyrex' 'protobuf' 'metacity' 'glu' 'libsm' 'dconf')
-makedepends=('cmake' 'bzr' 'intltool')
+depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'pygtk' 'desktop-file-utils' 'pyrex' 'protobuf' 'metacity' 'glu' 'libsm' 'dconf' 'python2-gobject')
+makedepends=('cmake' 'bzr' 'intltool' 'cython2')
optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
)
@@ -26,7 +26,7 @@ source=("${_bzrname}::bzr+http://bazaar.launchpad.net/~compiz-team/${_bzrname}/$
sha256sums=('SKIP'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
- '5da38bf4f7fd127a01ce9c68ab66d21fe69086228051073896d3d59c6bc400e8'
+ 'fba56d3e5fc8d1b47be2b8eaa6d79f48635daccc26db9b0b88fa281cc50c635e'
'89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61')
pkgver() {
@@ -49,6 +49,7 @@ prepare() {
# Use Python 2
find -type f \( -name 'CMakeLists.txt' -or -name '*.cmake' \) -exec sed -e 's/COMMAND python/COMMAND python2/g' -i {} \;
find compizconfig/ccsm -type f -exec sed -e 's|^#!.*python|#!/usr/bin/env python2|g' -i {} \;
+ sed -i "s/find_program(CYTHON_BIN cython)/find_program(CYTHON_BIN cython2)/g" compizconfig/compizconfig-python/CMakeLists.txt
# Fix incorrect extents for GTK+ tooltips, csd etc
patch -p1 -i "${srcdir}/gtk-extents.patch"
diff --git a/reverse-unity-config.patch b/reverse-unity-config.patch
index fec2a3754adc..e56309283078 100644
--- a/reverse-unity-config.patch
+++ b/reverse-unity-config.patch
@@ -1,6 +1,6 @@
diff -Nur original/compizconfig/integration/gnome/gsettings/org.compiz.integrated.gschema.xml modified/compizconfig/integration/gnome/gsettings/org.compiz.integrated.gschema.xml
---- original/compizconfig/integration/gnome/gsettings/org.compiz.integrated.gschema.xml 2017-12-18 09:57:24.000000000 +0000
-+++ modified/compizconfig/integration/gnome/gsettings/org.compiz.integrated.gschema.xml 2017-12-18 10:12:40.592440489 +0000
+--- original/compizconfig/integration/gnome/gsettings/org.compiz.integrated.gschema.xml 2018-08-06 18:15:54.363059834 +0100
++++ modified/compizconfig/integration/gnome/gsettings/org.compiz.integrated.gschema.xml 2018-08-06 18:16:43.161981494 +0100
@@ -10,9 +10,6 @@
<key type="s" name="command-screenshot">
<default>"gnome-screenshot"</default>
@@ -22,8 +22,8 @@ diff -Nur original/compizconfig/integration/gnome/gsettings/org.compiz.integrate
<default>""</default>
</key>
diff -Nur original/metadata/core.xml.in modified/metadata/core.xml.in
---- original/metadata/core.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/metadata/core.xml.in 2017-12-18 10:12:40.592440489 +0000
+--- original/metadata/core.xml.in 2018-08-06 18:15:54.383049834 +0100
++++ modified/metadata/core.xml.in 2018-08-06 18:16:43.165313161 +0100
@@ -144,7 +144,7 @@
<option name="focus_prevention_match" type="match">
<_short>Focus Prevention Windows</_short>
@@ -87,8 +87,8 @@ diff -Nur original/metadata/core.xml.in modified/metadata/core.xml.in
<max>32</max>
</option>
diff -Nur original/plugins/animation/animation.xml.in modified/plugins/animation/animation.xml.in
---- original/plugins/animation/animation.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/animation/animation.xml.in 2017-12-18 10:12:40.592440489 +0000
+--- original/plugins/animation/animation.xml.in 2018-08-06 18:15:54.403039834 +0100
++++ modified/plugins/animation/animation.xml.in 2018-08-06 18:16:43.171976494 +0100
@@ -36,7 +36,7 @@
<extensible/>
<sort start="2"/>
@@ -228,8 +228,8 @@ diff -Nur original/plugins/animation/animation.xml.in modified/plugins/animation
<max>1</max>
<precision>0.01</precision>
diff -Nur original/plugins/commands/commands.xml.in modified/plugins/commands/commands.xml.in
---- original/plugins/commands/commands.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/commands/commands.xml.in 2017-12-18 10:12:40.595773805 +0000
+--- original/plugins/commands/commands.xml.in 2018-08-06 18:15:54.413034833 +0100
++++ modified/plugins/commands/commands.xml.in 2018-08-06 18:16:43.175308160 +0100
@@ -117,7 +117,7 @@
<option name="command20" type="string">
<_short>Command line 20</_short>
@@ -248,8 +248,8 @@ diff -Nur original/plugins/commands/commands.xml.in modified/plugins/commands/co
</group>
<group>
diff -Nur original/plugins/decor/decor.xml.in modified/plugins/decor/decor.xml.in
---- original/plugins/decor/decor.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/decor/decor.xml.in 2017-12-18 10:12:40.595773805 +0000
+--- original/plugins/decor/decor.xml.in 2018-08-06 18:15:54.453014834 +0100
++++ modified/plugins/decor/decor.xml.in 2018-08-06 18:21:54.379628141 +0100
@@ -31,7 +31,7 @@
<option name="active_shadow_opacity" type="float">
<_short>Shadow Opacity</_short>
@@ -281,14 +281,14 @@ diff -Nur original/plugins/decor/decor.xml.in modified/plugins/decor/decor.xml.i
<option name="command" type="string">
<_short>Command</_short>
<_long>Decorator command line that is executed if no decorator is already running.</_long>
-- <default>/usr/bin/gtk-window-decorator</default>
+- <default>gtk-window-decorator</default>
+ <default>exec \"${COMPIZ_BIN_PATH}compiz-decorator\"</default>
</option>
<option name="mipmap" type="bool">
<_short>Mipmap</_short>
diff -Nur original/plugins/expo/expo.xml.in modified/plugins/expo/expo.xml.in
---- original/plugins/expo/expo.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/expo/expo.xml.in 2017-12-18 10:12:40.595773805 +0000
+--- original/plugins/expo/expo.xml.in 2018-08-06 18:15:54.453014834 +0100
++++ modified/plugins/expo/expo.xml.in 2018-08-06 18:16:43.178639827 +0100
@@ -17,7 +17,6 @@
<plugin>wobbly</plugin>
<plugin>animation</plugin>
@@ -384,8 +384,8 @@ diff -Nur original/plugins/expo/expo.xml.in modified/plugins/expo/expo.xml.in
<option name="ground_color1" type="color">
<_short>Ground Color (near)</_short>
diff -Nur original/plugins/ezoom/ezoom.xml.in modified/plugins/ezoom/ezoom.xml.in
---- original/plugins/ezoom/ezoom.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/ezoom/ezoom.xml.in 2017-12-18 10:12:40.595773805 +0000
+--- original/plugins/ezoom/ezoom.xml.in 2018-08-06 18:15:54.453014834 +0100
++++ modified/plugins/ezoom/ezoom.xml.in 2018-08-06 18:16:43.191966494 +0100
@@ -30,7 +30,7 @@
<option type="button" name="zoom_in_button">
<_short>Zoom In Button</_short>
@@ -413,7 +413,7 @@ diff -Nur original/plugins/ezoom/ezoom.xml.in modified/plugins/ezoom/ezoom.xml.i
</option>
<option name="zoom_box_outline_color" type="color">
<_short>Zoom Box Outline Color</_short>
-@@ -331,7 +331,7 @@
+@@ -346,7 +346,7 @@
<option type="key" name="fit_to_window_key">
<_short>Fit zoomed area to window</_short>
<_long>Zooms in/out so the focused window is zoomed to the maximum while still being fully visible.</_long>
@@ -423,8 +423,8 @@ diff -Nur original/plugins/ezoom/ezoom.xml.in modified/plugins/ezoom/ezoom.xml.i
</subgroup>
</group>
diff -Nur original/plugins/fade/fade.xml.in modified/plugins/fade/fade.xml.in
---- original/plugins/fade/fade.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/fade/fade.xml.in 2017-12-18 10:12:40.595773805 +0000
+--- original/plugins/fade/fade.xml.in 2018-08-06 18:15:54.453014834 +0100
++++ modified/plugins/fade/fade.xml.in 2018-08-06 18:16:43.191966494 +0100
@@ -10,7 +10,6 @@
</requirement>
<relation type="after">
@@ -443,8 +443,8 @@ diff -Nur original/plugins/fade/fade.xml.in modified/plugins/fade/fade.xml.in
<option name="visual_bell" type="bell">
<_short>Visual Bell</_short>
diff -Nur original/plugins/gnomecompat/gnomecompat.xml.in modified/plugins/gnomecompat/gnomecompat.xml.in
---- original/plugins/gnomecompat/gnomecompat.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/gnomecompat/gnomecompat.xml.in 2017-12-18 10:12:40.599107122 +0000
+--- original/plugins/gnomecompat/gnomecompat.xml.in 2018-08-06 18:15:54.463009833 +0100
++++ modified/plugins/gnomecompat/gnomecompat.xml.in 2018-08-06 18:16:43.195298161 +0100
@@ -57,7 +57,6 @@
<option name="run_command_terminal_key" type="key">
<_short>Open a terminal</_short>
@@ -454,8 +454,8 @@ diff -Nur original/plugins/gnomecompat/gnomecompat.xml.in modified/plugins/gnome
</group>
</options>
diff -Nur original/plugins/grid/grid.xml.in modified/plugins/grid/grid.xml.in
---- original/plugins/grid/grid.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/grid/grid.xml.in 2017-12-18 10:12:40.599107122 +0000
+--- original/plugins/grid/grid.xml.in 2018-08-06 18:15:54.463009833 +0100
++++ modified/plugins/grid/grid.xml.in 2018-08-06 18:16:43.198629827 +0100
@@ -68,12 +68,12 @@
<option name="put_maximize_key" type="key">
<_short>Maximize Key</_short>
@@ -472,8 +472,8 @@ diff -Nur original/plugins/grid/grid.xml.in modified/plugins/grid/grid.xml.in
<option name="left_maximize" type="key">
<_short>Left Maximize</_short>
diff -Nur original/plugins/resize/resize.xml.in modified/plugins/resize/resize.xml.in
---- original/plugins/resize/resize.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/resize/resize.xml.in 2017-12-18 10:15:46.954831086 +0000
+--- original/plugins/resize/resize.xml.in 2018-08-06 18:15:54.522979833 +0100
++++ modified/plugins/resize/resize.xml.in 2018-08-06 18:16:43.201961494 +0100
@@ -56,7 +56,7 @@
<option name="maximize_vertically" type="bool">
<short>Maximize Vertically if screen edge hit</short>
@@ -512,8 +512,8 @@ diff -Nur original/plugins/resize/resize.xml.in modified/plugins/resize/resize.x
</option>
<option name="disable_blend" type="bool">
diff -Nur original/plugins/scale/scale.xml.in modified/plugins/scale/scale.xml.in
---- original/plugins/scale/scale.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/scale/scale.xml.in 2017-12-18 10:12:40.599107122 +0000
+--- original/plugins/scale/scale.xml.in 2018-08-06 18:15:54.522979833 +0100
++++ modified/plugins/scale/scale.xml.in 2018-08-06 18:16:43.201961494 +0100
@@ -21,7 +21,7 @@
<option name="spacing" type="int">
<_short>Spacing</_short>
@@ -603,8 +603,8 @@ diff -Nur original/plugins/scale/scale.xml.in modified/plugins/scale/scale.xml.i
<option name="initiate_group_edge" type="edge">
<_short>Initiate Window Picker For Window Group</_short>
diff -Nur original/plugins/staticswitcher/staticswitcher.xml.in modified/plugins/staticswitcher/staticswitcher.xml.in
---- original/plugins/staticswitcher/staticswitcher.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/staticswitcher/staticswitcher.xml.in 2017-12-18 10:12:40.599107122 +0000
+--- original/plugins/staticswitcher/staticswitcher.xml.in 2018-08-06 18:15:54.542969833 +0100
++++ modified/plugins/staticswitcher/staticswitcher.xml.in 2018-08-06 18:16:43.205293160 +0100
@@ -11,6 +11,7 @@
<relation type="after">
<plugin>composite</plugin>
@@ -682,8 +682,8 @@ diff -Nur original/plugins/staticswitcher/staticswitcher.xml.in modified/plugins
<value>0</value>
<_name>None</_name>
diff -Nur original/plugins/vpswitch/vpswitch.xml.in modified/plugins/vpswitch/vpswitch.xml.in
---- original/plugins/vpswitch/vpswitch.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/vpswitch/vpswitch.xml.in 2017-12-18 10:12:40.599107122 +0000
+--- original/plugins/vpswitch/vpswitch.xml.in 2018-08-06 18:15:54.552964834 +0100
++++ modified/plugins/vpswitch/vpswitch.xml.in 2018-08-06 18:16:43.208624827 +0100
@@ -95,11 +95,13 @@
<option name="next_button" type="button">
<_short>Move Next</_short>
@@ -699,8 +699,8 @@ diff -Nur original/plugins/vpswitch/vpswitch.xml.in modified/plugins/vpswitch/vp
</option>
<option name="initiate_button" type="button">
diff -Nur original/plugins/wall/wall.xml.in modified/plugins/wall/wall.xml.in
---- original/plugins/wall/wall.xml.in 2017-12-18 09:57:24.000000000 +0000
-+++ modified/plugins/wall/wall.xml.in 2017-12-18 10:12:40.602440439 +0000
+--- original/plugins/wall/wall.xml.in 2018-08-06 18:15:54.552964834 +0100
++++ modified/plugins/wall/wall.xml.in 2018-08-06 18:16:43.211956494 +0100
@@ -30,12 +30,12 @@
<option name="miniscreen" type="bool">
<_short>Show Live Viewport Previews</_short>
@@ -858,8 +858,8 @@ diff -Nur original/plugins/wall/wall.xml.in modified/plugins/wall/wall.xml.in
<option name="edgeflip_dnd" type="bool">
<_short>Edge Flip DnD</_short>
diff -Nur original/tests/system/xorg-gtest/tests/compiz_xorg_gtest_ewmh.cpp modified/tests/system/xorg-gtest/tests/compiz_xorg_gtest_ewmh.cpp
---- original/tests/system/xorg-gtest/tests/compiz_xorg_gtest_ewmh.cpp 2017-12-18 09:57:24.000000000 +0000
-+++ modified/tests/system/xorg-gtest/tests/compiz_xorg_gtest_ewmh.cpp 2017-12-18 10:12:40.602440439 +0000
+--- original/tests/system/xorg-gtest/tests/compiz_xorg_gtest_ewmh.cpp 2018-08-06 18:15:54.632924833 +0100
++++ modified/tests/system/xorg-gtest/tests/compiz_xorg_gtest_ewmh.cpp 2018-08-06 18:16:43.211956494 +0100
@@ -46,7 +46,7 @@
namespace