summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2021-09-24 17:42:14 -0700
committerShadowKyogre2021-09-24 17:42:14 -0700
commitae15983dbae92ccdba91d1418e9fdcc1c4426790 (patch)
tree9e6886676e5e69ecf39f14b85d71facec739edf9
parent04341b39a3a441826479d7226bc24988783c187c (diff)
downloadaur-compiz-core.tar.gz
Fix building against librsvg 2.51.0+
A commit introduced in librsvg 2.51.0+ renamed librsvg/librsvg-features.h to librsvg/rsvg-features.h . As a result, this broke the SVG plugin compile process. The following patch includes a fix for this, which will be submitted upstream soon.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--fix-rsvg-features-include.patch12
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 665f6f19bae8..945e94e9b56e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz-core
pkgdesc = This is the latest stable release of Compiz without DE deps
pkgver = 0.8.18
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/compiz/compiz-core/
arch = i686
arch = x86_64
@@ -24,7 +24,9 @@ pkgbase = compiz-core
options = !libtool
options = !emptydirs
source = https://gitlab.com/compiz/compiz-core/-/archive/v0.8.18/compiz-core-v0.8.18.tar.bz2
+ source = fix-rsvg-features-include.patch
sha256sums = e87018b2d6c9ab3da87d910b117a7ae35f64328eea485e6c2a532501b361144c
+ sha256sums = eeeb8629fb4757a8305aa782aae7dba41e82ab12b330e461b10a2b5935f68f77
pkgname = compiz-core
pkgdesc = This is the latest stable release of Compiz without DE deps (Core w/o decorator)
@@ -44,4 +46,3 @@ pkgname = compiz-gtk
depends = libxi
depends = libxcursor
depends = compiz-core
-
diff --git a/PKGBUILD b/PKGBUILD
index 27e0a1af3fa1..1631631a2d12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _micro=""
pkgbase=compiz-core
pkgname=(compiz-core compiz-gtk)
pkgver="${_pkgver}${_micro}"
-pkgrel=2
+pkgrel=3
pkgdesc="This is the latest stable release of Compiz without DE deps"
url="https://gitlab.com/compiz/${_upstream}/"
license=('GPL' 'LGPL' 'MIT')
@@ -23,7 +23,8 @@ arch=('i686' 'x86_64')
depends=('startup-notification' 'librsvg' 'dbus' 'glu' 'libxslt' 'libxrandr' 'libsm' 'libxcomposite' 'libxinerama' 'libxi' 'libxcursor')
makedepends=('intltool' 'libice')
options=(!libtool !emptydirs)
-source=("${url}-/archive/v${pkgver}/${_upstream}-v${pkgver}.tar.bz2")
+source=("${url}-/archive/v${pkgver}/${_upstream}-v${pkgver}.tar.bz2"
+"fix-rsvg-features-include.patch")
_configure_opts=(
--prefix=/usr
@@ -60,6 +61,12 @@ else
echo "Using GTK+2 for gtk-window-decorator" >&2
fi
+prepare()
+{
+ cd "${srcdir}/${_upstream}-v${pkgver}"
+ patch -Np1 -i "${srcdir}/fix-rsvg-features-include.patch"
+}
+
build()
{
cd "${srcdir}/${_upstream}-v${pkgver}"
@@ -136,4 +143,5 @@ package_compiz-gtk()
done
}
-sha256sums=('e87018b2d6c9ab3da87d910b117a7ae35f64328eea485e6c2a532501b361144c')
+sha256sums=('e87018b2d6c9ab3da87d910b117a7ae35f64328eea485e6c2a532501b361144c'
+ 'eeeb8629fb4757a8305aa782aae7dba41e82ab12b330e461b10a2b5935f68f77')
diff --git a/fix-rsvg-features-include.patch b/fix-rsvg-features-include.patch
new file mode 100644
index 000000000000..6fe302f5ad57
--- /dev/null
+++ b/fix-rsvg-features-include.patch
@@ -0,0 +1,12 @@
+diff -aur compiz-core/plugins/svg.c compiz-core.modified/plugins/svg.c
+--- compiz-core/plugins/svg.c 2021-09-24 17:15:53.604807992 -0700
++++ compiz-core.modified/plugins/svg.c 2021-09-24 17:34:27.267538329 -0700
+@@ -32,7 +32,7 @@
+ #include <librsvg/rsvg-cairo.h>
+ #endif
+ #ifndef LIBRSVG_FEATURES_H
+-#include <librsvg/librsvg-features.h>
++#include <librsvg/rsvg-features.h>
+ #endif
+
+ #include <X11/Xatom.h>