summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2020-04-28 08:41:33 -0700
committerShadowKyogre2020-04-28 08:41:33 -0700
commit77cde87a1ce58bf43e3baefe93bdf12f13aa6eeb (patch)
tree555282c43999ce9c1150981fa73f7abb85ad8b95
parent9aed94927daf20eda4f098193075100970c7dea0 (diff)
downloadaur-77cde87a1ce58bf43e3baefe93bdf12f13aa6eeb.tar.gz
bump to 0.8.18
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92dc37505e49..67e21b4d7a36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz-core
pkgdesc = This is the latest stable release of Compiz without DE deps
- pkgver = 0.8.16.1
- pkgrel = 2
+ pkgver = 0.8.18
+ pkgrel = 1
url = https://gitlab.com/compiz/compiz-core/
arch = i686
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = compiz-core
depends = libxinerama
options = !libtool
options = !emptydirs
- source = https://gitlab.com/compiz/compiz-core/-/archive/v0.8.16.1/compiz-core-v0.8.16.1.tar.bz2
- sha256sums = 4910b6a0a8ad49f04c3ec0472f12dc962b0205e427d0a3ac2a91520e9649fdb7
+ source = https://gitlab.com/compiz/compiz-core/-/archive/v0.8.18/compiz-core-v0.8.18.tar.bz2
+ sha256sums = e87018b2d6c9ab3da87d910b117a7ae35f64328eea485e6c2a532501b361144c
pkgname = compiz-core
pkgdesc = This is the latest stable release of Compiz without DE deps (Core w/o decorator)
@@ -40,3 +40,4 @@ pkgname = compiz-gtk
depends = libxcomposite
depends = libxinerama
depends = compiz-core
+
diff --git a/PKGBUILD b/PKGBUILD
index 0975fb725993..4034f6cf216c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ _use_marco=0
_use_gtk3=0
_upstream="compiz-core"
-_pkgver=0.8.16
-_micro=".1"
+_pkgver=0.8.18
+_micro=""
pkgbase=compiz-core
pkgname=(compiz-core compiz-gtk)
pkgver="${_pkgver}${_micro}"
-pkgrel=2
+pkgrel=1
pkgdesc="This is the latest stable release of Compiz without DE deps"
url="https://gitlab.com/compiz/${_upstream}/"
license=('GPL' 'LGPL' 'MIT')
@@ -40,24 +40,24 @@ if (("${_use_marco}" == 1));then
_configure_opts+=("--enable-marco")
makedepends+=("marco")
_use_gtk3=1
- msg "Marco theme support enabled with GTK+3"
+ echo "Marco theme support enabled with GTK+3" >&2
elif (("${_use_marco}" == 2));then
_configure_opts+=("--enable-marco")
makedepends+=("marco-gtk2")
_use_gtk3=0
- msg "Marco theme support enabled with GTK+2"
+ echo "Marco theme support enabled with GTK+2" >&2
else
_configure_opts+=("--disable-marco")
- msg "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it"
- msg "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk2"
+ echo "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it" >&2
+ echo "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk2" >&2
fi
if (("${_use_gtk3}" >= 1)); then
_configure_opts+=("--with-gtk=3.0")
- msg "Using GTK+3 for gtk-window-decorator"
+ echo "Using GTK+3 for gtk-window-decorator" >&2
else
_configure_opts+=("--with-gtk=2.0")
- msg "Using GTK+2 for gtk-window-decorator"
+ echo "Using GTK+2 for gtk-window-decorator" >&2
fi
build()
@@ -69,7 +69,7 @@ build()
if ! grep -q pkg_cv_GTK config.log;then
# make sure only compiz-core is created if gtk is missing
- msg "Making sure only $pkgbase is made, gtk+2 or gtk+3 is missing"
+ echo "Making sure only $pkgbase is made, gtk+2 or gtk+3 is missing" >&2
pkgname=("$pkgbase")
fi
make
@@ -136,4 +136,4 @@ package_compiz-gtk()
done
}
-sha256sums=('4910b6a0a8ad49f04c3ec0472f12dc962b0205e427d0a3ac2a91520e9649fdb7')
+sha256sums=('e87018b2d6c9ab3da87d910b117a7ae35f64328eea485e6c2a532501b361144c')