summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2019-02-17 00:29:00 +0000
committerCharles Bos2019-02-17 00:29:00 +0000
commit72188280d21332846b2dee56ec3db91cbe0d4b80 (patch)
tree426a7d9f0ab5f5d43fb1a9481c6f427d9d19a834
parent92146d432495dab2553a6be4ad0129f399c8c723 (diff)
downloadaur-72188280d21332846b2dee56ec3db91cbe0d4b80.tar.gz
Patch cmake file to stop glib-compile-schemas from being called during make install
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD11
-rw-r--r--no-compile-gschemas.patch19
3 files changed, 38 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19ca4f58f613..cc84a31b92a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compiz-git
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)
- pkgver = 0.9.13.1.r8.g3552c1f09
+ pkgver = 0.9.14.0.r0.gb340cc413
pkgrel = 1
url = https://launchpad.net/compiz
arch = i686
@@ -24,14 +24,14 @@ pkgbase = compiz-git
depends = metacity
depends = glu
optdepends = xorg-xprop: grab various window properties for use in window matching rules
- provides = compiz=0.9.13
- provides = compiz-core=0.9.13
- provides = compiz-bcop=0.9.13
- provides = ccsm=0.9.13
- provides = compiz-plugins-main=0.9.13
- provides = compiz-plugins-extra=0.9.13
- provides = compizconfig-python=0.9.13
- provides = libcompizconfig=0.9.13
+ provides = compiz=0.9.14
+ provides = compiz-core=0.9.14
+ provides = compiz-bcop=0.9.14
+ provides = ccsm=0.9.14
+ provides = compiz-plugins-main=0.9.14
+ provides = compiz-plugins-extra=0.9.14
+ provides = compizconfig-python=0.9.14
+ provides = libcompizconfig=0.9.14
conflicts = compiz
conflicts = compiz-core
conflicts = compiz-gtk
@@ -49,11 +49,13 @@ pkgbase = compiz-git
source = gtk-extents.patch
source = reverse-unity-config.patch
source = screenshot-launch-fix.patch
+ source = no-compile-gschemas.patch
sha256sums = SKIP
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = fba56d3e5fc8d1b47be2b8eaa6d79f48635daccc26db9b0b88fa281cc50c635e
sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
+ sha256sums = 4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a
pkgname = compiz-git
diff --git a/PKGBUILD b/PKGBUILD
index 0e6ff405fc89..8cb4b05ba1dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Nathan Hulse <nat.hulse@gmail.com>
pkgname=compiz-git
-pkgver=0.9.13.1.r8.g3552c1f09
+pkgver=0.9.14.0.r0.gb340cc413
pkgrel=1
_gitname=compiz
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)"
@@ -24,12 +24,14 @@ source=("git+https://git.launchpad.net/${_gitname}"
"focus-prevention-disable.patch"
"gtk-extents.patch"
"reverse-unity-config.patch"
- "screenshot-launch-fix.patch")
+ "screenshot-launch-fix.patch"
+ "no-compile-gschemas.patch")
sha256sums=('SKIP'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'fba56d3e5fc8d1b47be2b8eaa6d79f48635daccc26db9b0b88fa281cc50c635e'
- '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61')
+ '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
+ '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a')
pkgver() {
cd "${_gitname}"
@@ -54,6 +56,9 @@ prepare() {
# Fix application launching for the screenshot plugin
patch -p1 -i "${srcdir}/screenshot-launch-fix.patch"
+
+ # Don't try to compile gschemas during make install
+ patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
}
build() {
diff --git a/no-compile-gschemas.patch b/no-compile-gschemas.patch
new file mode 100644
index 000000000000..05627a858d2c
--- /dev/null
+++ b/no-compile-gschemas.patch
@@ -0,0 +1,19 @@
+diff -Nur original/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake modified/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake
+--- original/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake 2019-02-16 12:44:41.000000000 +0000
++++ modified/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake 2019-02-16 23:36:58.589706824 +0000
+@@ -15,9 +15,9 @@
+
+ find_program (GLIB_COMPILE_SCHEMAS glib-compile-schemas)
+
+-if (GLIB_COMPILE_SCHEMAS)
+-
+- message ("-- Recompiling GSettings schemas in ${SCHEMADIR}")
+- execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} ${SCHEMADIR})
+-
+-endif (GLIB_COMPILE_SCHEMAS)
++#if (GLIB_COMPILE_SCHEMAS)
++#
++# message ("-- Recompiling GSettings schemas in ${SCHEMADIR}")
++# execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} ${SCHEMADIR})
++#
++#endif (GLIB_COMPILE_SCHEMAS)