summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDriftini2025-03-26 20:35:04 +0100
committerDriftini2025-03-26 20:35:04 +0100
commitd0e1428596a91cdddcd3a2a4de006d03c0958da5 (patch)
tree76dd31fee179e41332c57c9fb2489a2e00a7972b
parent2e548a840f2193fdc6eeafcf1587cb1a1aa5aa85 (diff)
downloadaur-d0e1428596a91cdddcd3a2a4de006d03c0958da5.tar.gz
compiz-git initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2949cbe2bcc9..20a60f01b0ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = compiz-git
- pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
- pkgver = 0.9.14.2.r11.g8196e9c
- pkgrel = 4
+ pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM. Git release
+ pkgver = 0.9.14.2
+ pkgrel = 1
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
license = GPL-2.0-or-later
license = LGPL-2.1-or-later
license = MIT
+ makedepends = git
makedepends = boost
makedepends = cmake
makedepends = cython
- makedepends = git
makedepends = intltool
makedepends = ninja
makedepends = python-setuptools
@@ -36,8 +36,8 @@ pkgbase = compiz-git
provides = compiz-plugins-main=0.9.14
provides = compizconfig-python=0.9.14
provides = libcompizconfig=0.9.14
- provides = compiz=0.9.14
conflicts = ccsm
+ conflicts = compiz
conflicts = compiz-bcop
conflicts = compiz-core
conflicts = compiz-fusion-plugins-experimental
@@ -47,7 +47,6 @@ pkgbase = compiz-git
conflicts = compizconfig-python
conflicts = libcompizconfig
conflicts = simple-ccsm
- conflicts = compiz
source = compiz::git+https://git.launchpad.net/compiz
source = 0001-reverse-unity-config.patch
source = 0002-focus-prevention-disable.patch
diff --git a/PKGBUILD b/PKGBUILD
index 83fce15a22d6..7c62a0a8670d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer:
+# Maintainer: Driftini <yurisilveos741@gmail.com>
# Contributor: Robert Brzozowski <robson75@linux.pl>
# Contributor: Charles Bos <charlesbos1 AT gmail>
@@ -7,9 +7,9 @@
_pkgname='compiz'
pkgname="$_pkgname-git"
-pkgver=0.9.14.2.r11.g8196e9c
-pkgrel=4
-pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
+pkgver=0.9.14.2
+pkgrel=1
+pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM. Git release"
url="https://launchpad.net/compiz"
arch=('i686' 'x86_64')
license=(
@@ -34,10 +34,10 @@ depends=(
'python-gobject'
)
makedepends=(
+ 'git'
'boost'
'cmake'
'cython'
- 'git'
'intltool'
'ninja'
'python-setuptools'
@@ -63,6 +63,7 @@ provides=(
)
conflicts=(
'ccsm'
+ 'compiz'
'compiz-bcop'
'compiz-core'
'compiz-fusion-plugins-experimental'
@@ -74,12 +75,10 @@ conflicts=(
'simple-ccsm'
)
-provides+=("compiz=${pkgver:0:6}")
-conflicts+=('compiz')
-
_pkgsrc="$_pkgname"
+_pkgext="tar.xz"
source=(
- "$_pkgsrc"::"git+https://git.launchpad.net/compiz"
+ "${_pkgsrc}"::"git+https://git.launchpad.net/compiz"
# Reverse Unity specific configuration patches
"0001-reverse-unity-config.patch"
@@ -112,13 +111,13 @@ sha256sums=(
)
pkgver() {
- cd "$_pkgsrc"
+ cd "${_pkgsrc}"
git describe --long --tags --abbrev=7 --exclude='*[a-zA-Z][a-zA-Z]*' \
- | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd "$_pkgsrc"
+ cd "${_pkgsrc}"
local src
for src in "${source[@]}"; do