summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2020-05-17 03:51:15 +0100
committerCharles Bos2020-05-17 03:51:15 +0100
commitea3d5adebad5bb7c4fdc5433ed96b7c10dacc64b (patch)
treeae804b2b9c339dd0efb3dc5e43679e3e7b97a564
parent6a2f828afd18046161f9fe7340c1f0aed0ba93f4 (diff)
downloadaur-ea3d5adebad5bb7c4fdc5433ed96b7c10dacc64b.tar.gz
Patch a build issue introduced by gcc 10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--gcc10_common_fix.patch24
3 files changed, 35 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac587b3b5d33..2ddd71a962f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compiz-git
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)
- pkgver = 0.9.14.1.r0.gfbe199d6b
+ pkgver = 0.9.14.1.r0.g1b2352b58
pkgrel = 1
url = https://launchpad.net/compiz
arch = i686
@@ -50,12 +50,14 @@ pkgbase = compiz-git
source = reverse-unity-config.patch
source = screenshot-launch-fix.patch
source = no-compile-gschemas.patch
+ source = gcc10_common_fix.patch
sha256sums = SKIP
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = 6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b
sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
sha256sums = 4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a
+ sha256sums = 580f237fc4800669d5c50d9af392dd5f5cf2750131a9fa1d5edfd17df02d0a3c
pkgname = compiz-git
diff --git a/PKGBUILD b/PKGBUILD
index a35139a4b4d7..72ef79da7bf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Nathan Hulse <nat.hulse@gmail.com>
pkgname=compiz-git
-pkgver=0.9.14.1.r0.gfbe199d6b
+pkgver=0.9.14.1.r0.g1b2352b58
pkgrel=1
_gitname=compiz
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)"
@@ -25,13 +25,15 @@ source=("git+https://git.launchpad.net/${_gitname}"
"gtk-extents.patch"
"reverse-unity-config.patch"
"screenshot-launch-fix.patch"
- "no-compile-gschemas.patch")
+ "no-compile-gschemas.patch"
+ "gcc10_common_fix.patch")
sha256sums=('SKIP'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b'
'89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
- '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a')
+ '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a'
+ '580f237fc4800669d5c50d9af392dd5f5cf2750131a9fa1d5edfd17df02d0a3c')
pkgver() {
cd "${_gitname}"
@@ -55,6 +57,9 @@ prepare() {
# Don't try to compile gschemas during make install
patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
+
+ # Fix linker error that gets raised with gcc 10 due to multiple definitions
+ patch -p1 -i "${srcdir}/gcc10_common_fix.patch"
}
build() {
diff --git a/gcc10_common_fix.patch b/gcc10_common_fix.patch
new file mode 100644
index 000000000000..a5867b495160
--- /dev/null
+++ b/gcc10_common_fix.patch
@@ -0,0 +1,24 @@
+diff -Nur original/gtk/window-decorator/gtk-window-decorator.c modified/gtk/window-decorator/gtk-window-decorator.c
+--- original/gtk/window-decorator/gtk-window-decorator.c 2019-11-27 13:24:31.000000000 +0000
++++ modified/gtk/window-decorator/gtk-window-decorator.c 2020-05-17 00:28:11.586617947 +0100
+@@ -122,7 +122,7 @@
+
+ XRenderPictFormat *xformat_rgba;
+
+-const gchar * window_type_frames[WINDOW_TYPE_FRAMES_NUM] = {
++const gchar * __attribute__((__common__))window_type_frames[WINDOW_TYPE_FRAMES_NUM] = {
+ "normal", "modal_dialog", "dialog", "menu", "utility"
+ };
+
+diff -Nur original/gtk/window-decorator/gtk-window-decorator.h modified/gtk/window-decorator/gtk-window-decorator.h
+--- original/gtk/window-decorator/gtk-window-decorator.h 2019-11-27 13:24:31.000000000 +0000
++++ modified/gtk/window-decorator/gtk-window-decorator.h 2020-05-17 00:27:21.383286282 +0100
+@@ -272,7 +272,7 @@
+ } default_frame_references_t;
+
+ extern default_frame_references_t default_frames[WINDOW_TYPE_FRAMES_NUM * 2];
+-const gchar * window_type_frames[WINDOW_TYPE_FRAMES_NUM];
++const gchar * __attribute__((__common__))window_type_frames[WINDOW_TYPE_FRAMES_NUM];
+
+ extern char *program_name;
+