summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Dejonckheere2015-02-05 10:07:46 +0100
committerFlorian Dejonckheere2015-02-05 10:07:46 +0100
commitff5b7630d08b43eb52f32ae2b4f94f04bff77f6e (patch)
tree51aa00166f8ac585cbe64363da41b6ef32963bd6
downloadaur-ff5b7630d08b43eb52f32ae2b4f94f04bff77f6e.tar.gz
Flatten directory structure
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f27366eac535
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = compizconfig-backend-kconfig4
+ pkgdesc = Compizconfig backend for kconfig4
+ pkgver = 0.8.8
+ pkgrel = 1
+ url = http://www.compiz.org/
+ arch = i686
+ arch = x86_64
+ groups = compiz-fusion-kde
+ groups = compiz-fusion
+ license = GPL2
+ makedepends = cmake
+ makedepends = automoc4
+ depends = libcompizconfig
+ depends = kdelibs
+ depends = libxcomposite
+ depends = libxinerama
+ source = http://releases.compiz.org/0.8.8/compizconfig-backend-kconfig4-0.8.8.tar.bz2
+ sha1sums = d7a29339b47233ad53fe04ca0136fdb511b945ac
+
+pkgname = compizconfig-backend-kconfig4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95768b26d6ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Florian Dejonckheere <florian@floriandejonckheere.be>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=compizconfig-backend-kconfig4
+pkgver=0.8.8
+pkgrel=1
+pkgdesc="Compizconfig backend for kconfig4"
+arch=('i686' 'x86_64')
+url="http://www.compiz.org/"
+license=('GPL2')
+depends=('libcompizconfig' 'kdelibs' 'libxcomposite' 'libxinerama')
+makedepends=('cmake' 'automoc4')
+groups=('compiz-fusion-kde' 'compiz-fusion')
+source=("http://releases.compiz.org/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=('d7a29339b47233ad53fe04ca0136fdb511b945ac')
+
+build()
+{
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake "../${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}