summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaltazár Radics2022-02-24 00:03:27 +0100
committerBaltazár Radics2022-02-24 00:03:27 +0100
commit266d8ee2cdffb87e04b6b9a2b636ed2d2b1e5a7d (patch)
treebdb7f3fd9f7be91fe056b4d5726be194c3895256
downloadaur-266d8ee2cdffb87e04b6b9a2b636ed2d2b1e5a7d.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD56
-rw-r--r--compressure.desktop7
-rw-r--r--compressure.sh4
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ebbbb410f9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = compressure-git
+ pkgdesc = Puzzle game about designing complex computation units powered by high pressure steam
+ pkgver = r413.3794731
+ pkgrel = 1
+ url = https://github.com/brejc8/ComPressure
+ arch = x86_64
+ license = CCPL:by
+ makedepends = git
+ makedepends = autoconf
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_mixer
+ depends = sdl2_net
+ depends = sdl2_ttf
+ depends = libxcb
+ depends = zstd
+ depends = zlib
+ provides = compressure
+ conflicts = compressure
+ source = compressure::git+https://github.com/brejc8/ComPressure.git
+ source = git+https://github.com/dacap/clip.git
+ source = compressure.sh
+ source = compressure.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 6ddd2ec7ef2c9fcd761336000355fc0a067def83f832adcec6d4d57c3c01511c
+ sha256sums = 379fc8aa9624e30bd4b0fbf95308bc808f01594bf5b19a4a734b3c4791b754a1
+
+pkgname = compressure-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dfcb7c50dde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Baltazár Radics <baltazar.radics@gmail.com>
+_pkgname=compressure
+pkgname=$_pkgname-git
+pkgver=r413.3794731
+pkgrel=1
+pkgdesc='Puzzle game about designing complex computation units powered by high pressure steam'
+arch=(x86_64)
+url='https://github.com/brejc8/ComPressure'
+license=(CCPL:by)
+depends=(sdl2_image sdl2_mixer sdl2_mixer sdl2_net sdl2_ttf)
+makedepends=(git autoconf)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=(
+ $_pkgname::git+https://github.com/brejc8/ComPressure.git
+ git+https://github.com/dacap/clip.git
+ compressure.sh
+ compressure.desktop
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ '6ddd2ec7ef2c9fcd761336000355fc0a067def83f832adcec6d4d57c3c01511c'
+ '379fc8aa9624e30bd4b0fbf95308bc808f01594bf5b19a4a734b3c4791b754a1')
+
+pkgver() {
+ cd $_pkgname
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ git submodule init
+ git config submodule.clip.url ../clip
+ git submodule update
+}
+
+build() {
+ cd $_pkgname
+ autoreconf -i
+ ./configure \
+ --prefix=/usr \
+ --disable-dependency-tracking \
+ --disable-steam
+ make ComPressure
+}
+
+package() {
+ install -Dm755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
+ install -Dm644 $_pkgname.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop
+ cd $_pkgname
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$_pkgname LICENSE.md README.md
+ install -Dm644 -t "$pkgdir"/usr/share/$_pkgname fixed.ttf lang.json \
+ vent_steam.ogg move_steam.ogg music.ogg \
+ font.png icon.png levels.png texture.png tutorial.png
+ install -Dm755 ComPressure "$pkgdir"/usr/lib/$_pkgname
+}
diff --git a/compressure.desktop b/compressure.desktop
new file mode 100644
index 000000000000..0e26b2237cf8
--- /dev/null
+++ b/compressure.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=ComPressure
+Comment=Puzzle game about designing complex computation units powered by high pressure steam
+Icon=/usr/share/compressure/icon.png
+Exec=/usr/bin/compressure
+Categories=Game
diff --git a/compressure.sh b/compressure.sh
new file mode 100644
index 000000000000..2e9307c45ad3
--- /dev/null
+++ b/compressure.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd ${0%/*}/../share/compressure
+exec ../../lib/compressure