summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-09-13 11:02:49 +0100
committerWorMzy Tykashi2018-09-13 11:02:49 +0100
commit6f360310e8380c82d4b03eba58423f35ef06f5b6 (patch)
treedbac9912ccdabb4dccb98bc0a0d7029f49363a00
parente44c5d0ea2ab94e3cfcfb2caf719871c5cd34bee (diff)
downloadaur-6f360310e8380c82d4b03eba58423f35ef06f5b6.tar.gz
Switch to yshui fork, new version scheme
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e45ba9bd754..3b84ec013cc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = compton-git
pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version)
- pkgver = 0.1_beta2.87.g316eac0
+ pkgver = 1.r1.g265dc67_2018.09.10
pkgrel = 1
- url = https://github.com/chjj/compton
+ epoch = 1
+ url = https://github.com/yshui/compton
arch = i686
arch = x86_64
license = MIT
@@ -23,7 +24,7 @@ pkgbase = compton-git
optdepends = xorg-xprop: For compton-trans
provides = compton
conflicts = compton
- source = git+https://github.com/chjj/compton.git
+ source = git+https://github.com/yshui/compton.git
md5sums = SKIP
pkgname = compton-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c7b1e0ff9fc..c9ac90489879 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,12 @@
pkgname=compton-git
_gitname=compton
-pkgver=0.1_beta2.87.g316eac0
+epoch=1
+pkgver=1.r1.g265dc67_2018.09.10
pkgrel=1
pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version)"
arch=(i686 x86_64)
-url="https://github.com/chjj/compton"
+url="https://github.com/yshui/compton"
license=('MIT')
depends=('libgl' 'libdbus' 'libxcomposite' 'libxdamage' 'libxrandr' 'pcre' 'libconfig' 'libxinerama' 'hicolor-icon-theme')
makedepends=('git' 'asciidoc' 'mesa')
@@ -17,12 +18,14 @@ optdepends=('dbus: To control compton via D-Bus'
'xorg-xprop: For compton-trans')
provides=('compton')
conflicts=('compton')
-source=(git+"https://github.com/chjj/compton.git")
+source=(git+"https://github.com/yshui/compton.git")
md5sums=("SKIP")
pkgver() {
cd "${srcdir}/${_gitname}"
- git describe --tags | sed -e 's:v::' -e 's/-/./g'
+ _ver=$(git describe --long | sed 's/\([^-]*-g\)/r\1/')
+ _date=$(git log -1 --date=short --pretty=format:%cd)
+ printf "%s_%s\n" "$_ver" "$_date" | sed -e 's:v::' -e 's/-/./g'
}
build() {