summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Milette2018-01-04 16:16:52 -0500
committerCharles Milette2018-01-04 16:31:17 -0500
commitce714191c3fad2977473a4f1ce621307fcdcd420 (patch)
tree4d8f7a55555b2e73b99208bb522ea33b6a5488a0
parente44c5d0ea2ab94e3cfcfb2caf719871c5cd34bee (diff)
downloadaur-ce714191c3fad2977473a4f1ce621307fcdcd420.tar.gz
no blur limit version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--no-blur-limit.patch15
3 files changed, 30 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e45ba9bd754..0ea206728df9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = compton-git
- pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version)
+pkgbase = compton-no-blur-limit-git
+ pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version with no artificial limit on blur size)
pkgver = 0.1_beta2.87.g316eac0
pkgrel = 1
url = https://github.com/chjj/compton
@@ -24,7 +24,9 @@ pkgbase = compton-git
provides = compton
conflicts = compton
source = git+https://github.com/chjj/compton.git
+ source = no-blur-limit.patch
md5sums = SKIP
+ md5sums = 314bafdd671821cf2ed340b866e8004d
-pkgname = compton-git
+pkgname = compton-no-blur-limit-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c7b1e0ff9fc..16f1538036af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
+# Maintainer: Charles Milette <charles.milette@gmail.com>
# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
# Contributor: OK100 <ok100 at lavabit dot com>
# Contributor: Valère Monseur <valere dot monseur at ymail dot com>
-pkgname=compton-git
+pkgname=compton-no-blur-limit-git
_gitname=compton
pkgver=0.1_beta2.87.g316eac0
pkgrel=1
-pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version)"
+pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version with no artificial limit on blur size)"
arch=(i686 x86_64)
url="https://github.com/chjj/compton"
license=('MIT')
@@ -17,14 +18,19 @@ optdepends=('dbus: To control compton via D-Bus'
'xorg-xprop: For compton-trans')
provides=('compton')
conflicts=('compton')
-source=(git+"https://github.com/chjj/compton.git")
-md5sums=("SKIP")
+source=(git+"https://github.com/chjj/compton.git" "no-blur-limit.patch")
+md5sums=("SKIP" "314bafdd671821cf2ed340b866e8004d")
pkgver() {
cd "${srcdir}/${_gitname}"
git describe --tags | sed -e 's:v::' -e 's/-/./g'
}
+prepare() {
+ cd "$srcdir/$_gitname"
+ git apply ../no-blur-limit.patch
+}
+
build() {
cd "$srcdir/$_gitname"
make PREFIX=/usr
diff --git a/no-blur-limit.patch b/no-blur-limit.patch
new file mode 100644
index 000000000000..a937cf08849e
--- /dev/null
+++ b/no-blur-limit.patch
@@ -0,0 +1,15 @@
+diff --git a/src/compton.c b/src/compton.c
+index 92935a3..eceb681 100644
+--- a/src/compton.c
++++ b/src/compton.c
+@@ -5063,10 +5063,6 @@ parse_matrix(session_t *ps, const char *src, const char **endptr) {
+ printf_errf("(): Width/height not odd.");
+ goto parse_matrix_err;
+ }
+- if (wid > 16 || hei > 16) {
+- printf_errf("(): Matrix width/height too large.");
+- goto parse_matrix_err;
+- }
+
+ // Allocate memory
+ matrix = calloc(wid * hei + 2, sizeof(XFixed));