summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-10-15 11:39:27 +0100
committerWorMzy Tykashi2018-10-15 11:39:27 +0100
commit15c5ada0489f8868bdd52a03fb908d93a6a8a924 (patch)
treeef7742575dfa0bbfb5a3d91234c09d44d05b9cc9
parentc69151e34f044e7f024ef3abb937cc35c83c303d (diff)
downloadaur-15c5ada0489f8868bdd52a03fb908d93a6a8a924.tar.gz
Meson build system, more pkgver changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3096c5ceb25c..8d0efd6cdeaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compton-git
pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version)
- pkgver = Next.r558.gde6e2f5_2018.10.10
+ pkgver = 565_3.rc1.2.g93dd2d9_2018.10.15
pkgrel = 1
epoch = 2
url = https://github.com/yshui/compton
@@ -11,6 +11,7 @@ pkgbase = compton-git
makedepends = git
makedepends = asciidoc
makedepends = mesa
+ makedepends = meson
depends = libgl
depends = libev
depends = pcre
@@ -26,6 +27,7 @@ pkgbase = compton-git
optdepends = dbus: To control compton via D-Bus
optdepends = xorg-xwininfo: For compton-trans
optdepends = xorg-xprop: For compton-trans
+ optdepends = python: For compton-convgen.py
provides = compton
conflicts = compton
source = git+https://github.com/yshui/compton.git#branch=next
diff --git a/PKGBUILD b/PKGBUILD
index 641696b6eaf1..0097fb93d3bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=compton-git
_gitname=compton
epoch=2
-pkgver=Next.r558.gde6e2f5_2018.10.10
+pkgver=565_3.rc1.2.g93dd2d9_2018.10.15
pkgrel=1
pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version)"
arch=(i686 x86_64)
@@ -13,10 +13,11 @@ url="https://github.com/yshui/compton"
license=('MIT' 'MPL2')
depends=('libgl' 'libev' 'pcre' 'libx11' 'xcb-util-renderutil' 'libxcb' 'xcb-util-image' 'libxext'
'pixman' 'libconfig' 'libdbus' 'hicolor-icon-theme')
-makedepends=('git' 'asciidoc' 'mesa')
+makedepends=('git' 'asciidoc' 'mesa' 'meson')
optdepends=('dbus: To control compton via D-Bus'
'xorg-xwininfo: For compton-trans'
- 'xorg-xprop: For compton-trans')
+ 'xorg-xprop: For compton-trans'
+ 'python: For compton-convgen.py')
provides=('compton')
conflicts=('compton')
source=(git+"https://github.com/yshui/compton.git#branch=next")
@@ -24,27 +25,26 @@ md5sums=("SKIP")
pkgver() {
cd ${_gitname}
- _tag=$(git describe --tags | sed 's:^v::') # tag is mobile, so we can't rely on --long being incremental :(
- _commits=$(git rev-list --count HEAD)
- _hash=$(git rev-parse --short HEAD)
+ _tag=$(git describe --tags | sed 's:^v::') # tag is mobile, and switches between numbers and letters, can't use it for versioning
+ _commits=$(git rev-list --count HEAD) # total commits is the most sane way of getting incremental pkgver
_date=$(git log -1 --date=short --pretty=format:%cd)
- printf "%s.r%s.g%s_%s\n" "${_tag}" "${_commits}" "${_hash}" "${_date}" | sed 's/-/./g'
+ printf "%s_%s_%s\n" "${_commits}" "${_tag}" "${_date}" | sed 's/-/./g'
}
build() {
- cd "$srcdir/$_gitname"
- make PREFIX=/usr
- make docs
+ cd "${srcdir}/${_gitname}"
+ meson --buildtype=release . build --prefix=/usr
+ ninja -C build
}
package() {
- cd "$srcdir/$_gitname"
+ cd "${srcdir}/${_gitname}"
- make PREFIX="$pkgdir/usr" install
+ DESTDIR="${pkgdir}" ninja -C build install
# install license
- install -D -m644 "LICENSES/MIT" "$pkgdir/usr/share/licenses/$_gitname/LICENSE-MIT"
+ install -D -m644 "LICENSES/MIT" "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE-MIT"
# example conf
- install -D -m644 "compton.sample.conf" "$pkgdir/etc/xdg/compton.conf.example"
+ install -D -m644 "compton.sample.conf" "${pkgdir}/etc/xdg/compton.conf.example"
}