summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-09 23:14:52 +0100
committerWorMzy Tykashi2015-06-09 23:14:52 +0100
commit88d5338d9bc745c915c9f341bf05a3c742b64dad (patch)
treee1fc55b7e666d7c07fb93d912bfa46252596669c
downloadaur-88d5338d9bc745c915c9f341bf05a3c742b64dad.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5f3b89d164f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = compton-git
+ pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version)
+ pkgver = 0.1_beta2.68.gb1889c1
+ pkgrel = 1
+ url = https://github.com/chjj/compton
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = asciidoc
+ makedepends = mesa
+ depends = libgl
+ depends = libdbus
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxrandr
+ depends = pcre
+ depends = libconfig
+ depends = libxinerama
+ optdepends = dbus: To control compton via D-Bus
+ optdepends = xorg-xwininfo: For compton-trans
+ optdepends = xorg-xprop: For compton-trans
+ provides = compton
+ conflicts = compton
+ source = git://github.com/chjj/compton.git
+ md5sums = SKIP
+
+pkgname = compton-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ac324466616
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: OK100 <ok100 at lavabit dot com>
+# Contributor: Valère Monseur <valere dot monseur at ymail dot com>
+
+pkgname=compton-git
+_gitname=compton
+pkgver=0.1_beta2.68.gb1889c1
+pkgrel=1
+pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version)"
+arch=(i686 x86_64)
+url="https://github.com/chjj/compton"
+license=('MIT')
+depends=('libgl' 'libdbus' 'libxcomposite' 'libxdamage' 'libxrandr' 'pcre' 'libconfig' 'libxinerama')
+makedepends=('git' 'asciidoc' 'mesa')
+optdepends=('dbus: To control compton via D-Bus'
+ 'xorg-xwininfo: For compton-trans'
+ 'xorg-xprop: For compton-trans')
+provides=('compton')
+conflicts=('compton')
+source=("git://github.com/chjj/compton.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --tags | sed -e 's:v::' -e 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make PREFIX=/usr
+ make docs
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ make PREFIX="$pkgdir/usr" install
+
+ # install license
+ install -D -m644 "LICENSE" "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+
+ # example conf
+ install -D -m644 "compton.sample.conf" "$pkgdir/etc/xdg/compton.conf.example"
+}