summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-11-03 13:19:32 +0000
committerWorMzy Tykashi2018-11-03 13:19:32 +0000
commit8bb0b9a5e70d789124fe878885810f2d0d02b89d (patch)
treece8d19955d78da27e058366e6294e7d616553762
parent9a46a3ddd275ffec14e67de4d2826a8d94813414 (diff)
downloadaur-8bb0b9a5e70d789124fe878885810f2d0d02b89d.tar.gz
Make manpage generation optional
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f486515aff1..55f872a9dcf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compton-git
pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version)
- pkgver = 585_Next.3.gc0d7f9d_2018.10.29
+ pkgver = 590_Next_2018.11.02
pkgrel = 1
epoch = 2
url = https://github.com/yshui/compton
diff --git a/PKGBUILD b/PKGBUILD
index 086a917afa59..9fa5edd57872 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Contributor: OK100 <ok100 at lavabit dot com>
# Contributor: Valère Monseur <valere dot monseur at ymail dot com>
+_BUILDOPTS='' # Prevent environment variables breaking build
pkgname=compton-git
_gitname=compton
epoch=2
-pkgver=585_Next.3.gc0d7f9d_2018.10.29
+pkgver=590_Next_2018.11.02
pkgrel=1
pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version)"
arch=(i686 x86_64)
@@ -23,6 +24,10 @@ conflicts=('compton')
source=(git+"https://github.com/yshui/compton.git#branch=next")
md5sums=("SKIP")
+# Upstream disables manpage generation by default, to enable, uncomment the next two lines
+#makedepends+=('asciidoc')
+#_BUILDOPTS='-Dbuild_docs=true'
+
pkgver() {
cd ${_gitname}
_tag=$(git describe --tags | sed 's:^v::') # tag is mobile, and switches between numbers and letters, can't use it for versioning
@@ -33,7 +38,7 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
- meson --buildtype=release . build --prefix=/usr
+ meson --buildtype=release . build --prefix=/usr ${_BUILDOPTS}
ninja -C build
}