summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-11-08 22:14:54 +0000
committerWorMzy Tykashi2018-11-08 22:14:54 +0000
commitab6f4c765115c4e2d2fd53a9ed9abc8b59fd1af2 (patch)
tree9ad98b80b4b76b3fe41aa6a97544233511605f3f
parent8bb0b9a5e70d789124fe878885810f2d0d02b89d (diff)
downloadaur-ab6f4c765115c4e2d2fd53a9ed9abc8b59fd1af2.tar.gz
Re-enable manpage generation by default
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55f872a9dcf6..caf8a451c2ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compton-git
pkgdesc = X Compositor (a fork of xcompmgr-dana) (git-version)
- pkgver = 590_Next_2018.11.02
+ pkgver = 599_Next.4.gb18d46b_2018.11.08
pkgrel = 1
epoch = 2
url = https://github.com/yshui/compton
@@ -11,6 +11,7 @@ pkgbase = compton-git
makedepends = git
makedepends = mesa
makedepends = meson
+ makedepends = asciidoc
depends = libgl
depends = libev
depends = pcre
diff --git a/PKGBUILD b/PKGBUILD
index 9fa5edd57872..96d227c93212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,10 @@
# Contributor: OK100 <ok100 at lavabit dot com>
# Contributor: Valère Monseur <valere dot monseur at ymail dot com>
-_BUILDOPTS='' # Prevent environment variables breaking build
pkgname=compton-git
_gitname=compton
epoch=2
-pkgver=590_Next_2018.11.02
+pkgver=599_Next.4.gb18d46b_2018.11.08
pkgrel=1
pkgdesc="X Compositor (a fork of xcompmgr-dana) (git-version)"
arch=(i686 x86_64)
@@ -14,7 +13,7 @@ url="https://github.com/yshui/compton"
license=('MIT' 'MPL2')
depends=('libgl' 'libev' 'pcre' 'libx11' 'xcb-util-renderutil' 'libxcb' 'xcb-util-image' 'libxext'
'pixman' 'libconfig' 'libdbus' 'hicolor-icon-theme')
-makedepends=('git' 'mesa' 'meson')
+makedepends=('git' 'mesa' 'meson' 'asciidoc')
optdepends=('dbus: To control compton via D-Bus'
'xorg-xwininfo: For compton-trans'
'xorg-xprop: For compton-trans'
@@ -24,10 +23,6 @@ conflicts=('compton')
source=(git+"https://github.com/yshui/compton.git#branch=next")
md5sums=("SKIP")
-# Upstream disables manpage generation by default, to enable, uncomment the next two lines
-#makedepends+=('asciidoc')
-#_BUILDOPTS='-Dbuild_docs=true'
-
pkgver() {
cd ${_gitname}
_tag=$(git describe --tags | sed 's:^v::') # tag is mobile, and switches between numbers and letters, can't use it for versioning
@@ -38,7 +33,7 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
- meson --buildtype=release . build --prefix=/usr ${_BUILDOPTS}
+ meson --buildtype=release . build --prefix=/usr -Dbuild_docs=true
ninja -C build
}