aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrmat2018-05-24 23:35:22 +0200
committergrmat2018-05-24 23:35:22 +0200
commit576f975585c1bb951892e37716e8b22d060ce199 (patch)
tree33e7467cad2d0e429cc6abf7f6ca50ad186ac0ae
parent13ea26c272d378ec6d2b7792224f254ff0a4d50a (diff)
downloadaur-576f975585c1bb951892e37716e8b22d060ce199.tar.gz
add -git version of package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
-rw-r--r--README.md4
3 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a43006be19a..1cee43859f33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = compute-runtime
- pkgdesc = Intel(R) Graphics Compute Runtime for OpenCL(TM). Replaces Beignet for Gen8 (Broadwell) and beyond. Weekly build version.
- pkgver = 18.20.10830
+pkgbase = compute-runtime-git
+ pkgdesc = Intel(R) Graphics Compute Runtime for OpenCL(TM). Replaces Beignet for Gen8 (Broadwell) and beyond. Git version.
+ pkgver = 18.20.10830.r19.g01c1df3
pkgrel = 1
url = https://01.org/compute-runtime
arch = x86_64
@@ -13,15 +13,15 @@ pkgbase = compute-runtime
depends = ocl-icd
optdepends = libva: for cl_intel_va_api_media_sharing
optdepends = libdrm: for cl_intel_va_api_media_sharing
- conflicts = compute-runtime-git
- source = neo::git+https://github.com/intel/compute-runtime#tag=18.20.10830
+ conflicts = compute-runtime
+ source = neo::git+https://github.com/intel/compute-runtime
source = clang_source::git+https://github.com/llvm-mirror/clang#branch=release_40
- source = common_clang::git+https://github.com/intel/opencl-clang#commit=fa75886
- source = llvm_patches::git+https://github.com/intel/llvm-patches#commit=0ba9deb
+ source = common_clang::git+https://github.com/intel/opencl-clang
+ source = llvm_patches::git+https://github.com/intel/llvm-patches
source = llvm_source::git+https://github.com/llvm-mirror/llvm#branch=release_40
- source = gmmlib::git+https://github.com/intel/gmmlib#commit=a501534
- source = igc::git+https://github.com/intel/intel-graphics-compiler#commit=858e183
- source = khronos::git+https://github.com/KhronosGroup/OpenCL-Headers#commit=de26592
+ source = gmmlib::git+https://github.com/intel/gmmlib
+ source = igc::git+https://github.com/intel/intel-graphics-compiler
+ source = khronos::git+https://github.com/KhronosGroup/OpenCL-Headers
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -31,5 +31,5 @@ pkgbase = compute-runtime
sha256sums = SKIP
sha256sums = SKIP
-pkgname = compute-runtime
+pkgname = compute-runtime-git
diff --git a/PKGBUILD b/PKGBUILD
index f3cec9bd32e7..846b4d16a2e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: grmat <grmat@sub.red>
-pkgname='compute-runtime'
-pkgdesc="Intel(R) Graphics Compute Runtime for OpenCL(TM). Replaces Beignet for Gen8 (Broadwell) and beyond. Weekly build version."
-pkgver='18.20.10830'
+pkgname='compute-runtime-git'
+pkgdesc="Intel(R) Graphics Compute Runtime for OpenCL(TM). Replaces Beignet for Gen8 (Broadwell) and beyond. Git version."
+pkgver='18.20.10830.r19.g01c1df3'
pkgrel=1
arch=('x86_64')
url='https://01.org/compute-runtime'
@@ -11,16 +11,16 @@ makedepends=('gcc54' 'llvm' 'clang' 'python2' 'opencl-headers')
optdepends=('libva: for cl_intel_va_api_media_sharing'
'libdrm: for cl_intel_va_api_media_sharing')
depends=('ocl-icd')
-conflicts=('compute-runtime-git')
+conflicts=('compute-runtime')
-source=("neo::git+https://github.com/intel/compute-runtime#tag=18.20.10830"
+source=("neo::git+https://github.com/intel/compute-runtime"
"clang_source::git+https://github.com/llvm-mirror/clang#branch=release_40"
- "common_clang::git+https://github.com/intel/opencl-clang#commit=fa75886"
- "llvm_patches::git+https://github.com/intel/llvm-patches#commit=0ba9deb"
+ "common_clang::git+https://github.com/intel/opencl-clang"
+ "llvm_patches::git+https://github.com/intel/llvm-patches"
"llvm_source::git+https://github.com/llvm-mirror/llvm#branch=release_40"
- "gmmlib::git+https://github.com/intel/gmmlib#commit=a501534"
- "igc::git+https://github.com/intel/intel-graphics-compiler#commit=858e183"
- "khronos::git+https://github.com/KhronosGroup/OpenCL-Headers#commit=de26592")
+ "gmmlib::git+https://github.com/intel/gmmlib"
+ "igc::git+https://github.com/intel/intel-graphics-compiler"
+ "khronos::git+https://github.com/KhronosGroup/OpenCL-Headers")
sha256sums=('SKIP'
'SKIP'
@@ -31,6 +31,11 @@ sha256sums=('SKIP'
'SKIP'
'SKIP')
+pkgver() {
+ cd "${srcdir}/neo"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${srcdir}"
mkdir "${srcdir}/build"
diff --git a/README.md b/README.md
index 266271a86484..be03af10e2c3 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,6 @@
-# compute-runtime
+# compute-runtime-git
-Arch package for intel's OpenCL 2.x [compute-runtime], weekly build version.
+Arch package for intel's OpenCL 2.x [compute-runtime], git version.
Also see [01.org].
[compute-runtime]: https://github.com/intel/compute-runtime