aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrmat2018-06-27 21:13:16 +0200
committergrmat2018-06-27 21:13:16 +0200
commita3efb7f77ee55e89c4cee35c6fb313b874385a61 (patch)
treea5eb7d23c667946eb5eec0243ce1e749b35bbfc8
parent138a3192caa6c34fd25a43bf80b340d491952fc2 (diff)
downloadaur-a3efb7f77ee55e89c4cee35c6fb313b874385a61.tar.gz
remove gcc54 from deps, opencl headers from sources
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5306ff3d779c..e25f59f82bf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = compute-runtime-git
arch = x86_64
license = MIT
makedepends = git
- makedepends = gcc54
makedepends = llvm
makedepends = clang
makedepends = python2
@@ -22,8 +21,6 @@ pkgbase = compute-runtime-git
source = llvm_source::git+https://github.com/llvm-mirror/llvm#branch=release_40
source = gmmlib::git+https://github.com/intel/gmmlib
source = igc::git+https://github.com/intel/intel-graphics-compiler
- source = khronos::git+https://github.com/KhronosGroup/OpenCL-Headers
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a330488cf8ec..07176cb57198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname='compute-runtime-git'
pkgdesc="Intel(R) Graphics Compute Runtime for OpenCL(TM). Replaces Beignet for Gen8 (Broadwell) and beyond. Git version."
-pkgver=18.23.10915.r37.g0c84994
+pkgver=18.25.10965.r28.ge18e9fb
pkgrel=1
arch=('x86_64')
url='https://01.org/compute-runtime'
license=('MIT')
-makedepends=('git' 'gcc54' 'llvm' 'clang' 'python2' 'opencl-headers')
+makedepends=('git' 'llvm' 'clang' 'python2' 'opencl-headers')
optdepends=('libva: for cl_intel_va_api_media_sharing'
'libdrm: for cl_intel_va_api_media_sharing')
depends=('ocl-icd')
@@ -19,8 +19,7 @@ source=("neo::git+https://github.com/intel/compute-runtime"
"llvm_patches::git+https://github.com/intel/llvm-patches"
"llvm_source::git+https://github.com/llvm-mirror/llvm#branch=release_40"
"gmmlib::git+https://github.com/intel/gmmlib"
- "igc::git+https://github.com/intel/intel-graphics-compiler"
- "khronos::git+https://github.com/KhronosGroup/OpenCL-Headers")
+ "igc::git+https://github.com/intel/intel-graphics-compiler")
sha256sums=('SKIP'
'SKIP'
@@ -28,7 +27,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -46,10 +44,6 @@ build() {
# doesn't build with gcc8 and gcc54 doesn't know -fno-plt
cmake -DBUILD_TYPE=Release \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_COMPILER=gcc-5 \
- -DCMAKE_CXX_COMPILER=g++-5 \
- -DCMAKE_C_FLAGS="${CFLAGS/'-fno-plt'/}" \
- -DCMAKE_CXX_FLAGS="${CFLAGS/'-fno-plt'/}" \
../neo
make "$MAKEFLAGS"
}