summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-08-13 21:12:44 -0400
committerChris Severance2017-08-13 21:12:44 -0400
commit62509d7b6921c93c333c964d07a4d021d4e640d6 (patch)
treec7aa002232140e83d5aa82553dcce5d8636e858a
downloadaur-62509d7b6921c93c333c964d07a4d021d4e640d6.tar.gz
Initial Import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08223c1e3609
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Aug 14 00:56:30 UTC 2017
+pkgbase = comtrol-lcom
+ pkgdesc = open multiple serial ports or TCP/IP connections and exercise them in different ways
+ pkgver = 1.06
+ pkgrel = 1
+ url = http://downloads.comtrol.com/html/DM_PRO_RTS_SERIALHUB_drivers.htm
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ncurses
+ source = http://downloads.comtrol.com/utilities/linux/lcom/lcom-1.06.tar.gz
+ sha256sums = ace5a3ca00addfc10b94c065faacf73a2bb5f6ab916e05fc7035186d9cf79e1e
+
+pkgname = comtrol-lcom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f184dcdf0b38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+set -u
+pkgname='comtrol-lcom'
+pkgver='1.06'
+pkgrel='1'
+pkgdesc='open multiple serial ports or TCP/IP connections and exercise them in different ways'
+arch=('i686' 'x86_64')
+url='http://downloads.comtrol.com/html/DM_PRO_RTS_SERIALHUB_drivers.htm'
+license=('custom')
+depends=('ncurses')
+_verwatch=('http://downloads.comtrol.com/html/DM_PRO_RTS_SERIALHUB_drivers.htm' '../utilities/linux/lcom/lcom-\([0-9\.]\+\)\.tar\.gz' 'l')
+_srcdir="${pkgname##*-}-${pkgver}"
+source=("http://downloads.comtrol.com/utilities/linux/lcom/lcom-${pkgver}.tar.gz")
+sha256sums=('ace5a3ca00addfc10b94c065faacf73a2bb5f6ab916e05fc7035186d9cf79e1e')
+
+prepare() {
+ set -u
+ cd "${_srcdir}"
+ find -type 'f' -exec chmod 644 '{}' '+'
+ sed -e 's:\r$::g' -i 'README'
+
+ # Make install package compatible
+ sed -e 's:/usr/local/bin:/usr/bin:g' \
+ -e 's:/usr/local/man:/usr/share/man:g' \
+ -e '/^install:/,/^$/ s: /usr: "$(DESTDIR)"/usr:g' \
+ -i 'Makefile'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${_srcdir}"
+ make -s -j1 # too small for parallel make
+ set +u
+}
+
+package() {
+ set -u
+ cd "${_srcdir}"
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/man/man1"
+ make -j1 DESTDIR="${pkgdir}" install
+ set +u
+}
+
+set +u